1

I am trying to prepare a presentation with Beamer. I have two laptops one of them is a 2015 MacBook Air i7 and the other one is a MacBook Air M2. I am using TexShop with the same version, version 5.12, on both laptops. On my old laptop everything works fine but on the new one, when I tried to write something in the block environment a black frame appear on the blocks, see first photo. I tried many things but couldn't find a solution. By the way in the log file, I have the following error message: %%%% WARNING: Transparency operations ignored - need to use -dALLOWPSTRANSPARENCY. I also searched a solution for this error but couldn't find one being applicable to the TexShop. Is there anyone have an idea about this problem? Thank you in advance.

Ps: If I typeset the file with LuaLaTeX it works without the black frame. But in this case, the universal letters (Turkish letters in my case) do not appear in the dvi. Is there any solution to show accent letters in LuaLaTeX?

Edit: I am using MacTeX April version. I checked the TeX Live Utility and its version is 1.54. Below, I present the commands which produce the first photo I gave.

\documentclass[xcolor={dvipsnames,table},t]{beamer}
\usetheme{Berlin}
\usecolortheme{whale}
\setbeamercolor*{palette tertiary{use=structure,fg=white,bg=black}
\setbeamercolor*{palette quaternary}{fg=white,bg=black}
\setbeamercolor{frametitle}{bg=structure!75,fg=white}
\setbeamercolor{block title}{bg=structure!75,fg=white}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[shorthands=off,turkish]{babel}
\begin{document}
\begin{frame}[t]
\begin{block}{balabal}
 blabala
\end{block}
\end{frame}
\end{document}

If I typeset the same codes with LuaLaTeX I obtain the second photo.

Interestingly now only some Turkish characters, ı,ş etc., do not appear and some, ü, ç, etc, appear.
[1]: https://i.stack.imgur.com/4DCuR.png [2]: https://i.stack.imgur.com/bUYgl.png

6
  • How do you compile your document? May 17, 2023 at 15:43
  • It would also be nice if you could mention which version of texlive you have installed and add a short but compilable test document which reproduces your problems with Turkish letters. May 17, 2023 at 15:52
  • I am away from the laptop now. I will post as soon as possible.
    – Banx
    May 17, 2023 at 16:44
  • I guess this is a problem of a beamer package dated 2020 or earlier, see Annoying black color appears on beamer block after some edits. Upgrading the package or the whole TeX distro should fix the issue.
    – gernot
    May 17, 2023 at 17:09
  • @Banx Which tools do you use to compile your code? Do you compile via latex->dvips->ps2pdf? If yes try with ps2pdf -dALLOWPSTRANSPARENCY instead May 17, 2023 at 20:19

1 Answer 1

1

If you compile with lualatex, remove the fontenc package to get your Turkish letters.

(... and the closing } after {palette tertiary is missing)

% !TeX TS-program = lualatex

\documentclass[xcolor={dvipsnames,table},t]{beamer}
\usetheme{Berlin}
\usecolortheme{whale}
\setbeamercolor*{palette tertiary}{use=structure,fg=white,bg=black}
\setbeamercolor*{palette quaternary}{fg=white,bg=black}
\setbeamercolor{frametitle}{bg=structure!75,fg=white}
\setbeamercolor{block title}{bg=structure!75,fg=white}
%\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[shorthands=off,turkish]{babel}
\begin{document}
\begin{frame}[t]

Interestingly now only some Turkish characters, ı,ş etc., do not appear and some, ü, ç, etc, appear.

\begin{block}{balabal}
 blabala
\end{block}
\end{frame}
\end{document}

enter image description here

4
  • Thanks, @samcarter_is_at_topanswers.xyz. In the original file, I have the missing "}" palette tertiary. It works correctly with LuaLaTeX now. But still, I don't understand why it doesn't work on one laptop, but, works with the other one while compiling via LaTeX.
    – Banx
    May 17, 2023 at 21:04
  • @Banx I suspect that on your one laptop, you have an old version of ghostscript, which is used when converting from ps to pdf if you compile with via the dvi route. In this old ghostscript version, transparency was allowed by default. In newer gs version, transparency is off by default for security reasons. This is why new versions need to be called need to be called with the -dALLOWPSTRANSPARENCY option. If you use pdflatex, lualatex etc. you don't have this intermediate step and directly compile to pdf, thus you don't run into problems with ghostscript. May 17, 2023 at 21:29
  • Thank you for the explanation. Probably it is the reason. Because I also updated Ghostscript via Terminal on the new laptop. Do you know any way to allow -dALLOWPSTRANSPARENCY option for MacBook maybe using Terminal?
    – Banx
    May 18, 2023 at 4:58
  • @Banx You need to configure texshop to run dvips with the -dALLOWPSTRANSPARENCY option (... or whatever other tools are used in this TexShop Tex+DVI procedure....) May 18, 2023 at 11:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .