0

I'm writing a document using the scrbook class, and I'm having some strange behavior when combing floats with the \part macro.

For the following document:

\documentclass{scrbook}

\begin{document}

\part{A Part} % This line seems to be creating the problem. If you comment it out, you'll notice that the extra "." character disappears.

\chapter{A Chapter}

\section{A Section}

\begin{figure}
    \centering
    \textit{The contents of the figure go here.}
    \caption{A Figure.}
    \label{Test}
\end{figure}
\end{document}

I would expect the output to look something like this:

Page with contents: "1 A Chapter [newline] 1.1 A Section [at bottom of page] The contents of the figure go here. [newline] Figure 1.1: A Figure.

Instead, it looks like this:

Page with contents: "1. A Chapter [newline] 1.1. A Section [at bottom of page] The contents of the figure go here. [newline] Figure 1.1.: A Figure.

The difference is very subtle, but there is a period after the name of the figure and before the colon, which looks odd:

Figure 1.1.: A Figure.

How can this period be removed?

1
  • I linked to that in my answer to this question—it's the same solution, but for a different problem. I wrote this question and answer because I wanted people to be able to find it in case they had the same problem. I'm also wondering if it's possible to remove just the extra period after "Figure 1.1." without changing the rest of the section titles. May 26, 2023 at 16:39

1 Answer 1

0

According to the KOMA-Script documentation:

According to DUDEN, if only Arabic numerals are used to number section headings, the German practice is to have no point at the end (see [DUD96, R 3]). On the other hand, if Roman numerals or letters appear in the numbering, then a point should appear at the end of the numbering (see [DUD96, R 4]). KOMA-Script has a mechanism that tries to automate this somewhat complex rule.

Unfortunately, as of 2023, it appears that the KOMA-Script book class also applies this convention everywhere if Roman numerals are used anywhere in the document. The part created by \part{A Part} uses a Roman numeral in the example above, so periods appear after all automatic section/float numbers in the rest of the document. To fix this, you can explicitly disable the automatic application of this convention by loading the KOMA-Script book class with the numbers=noendperiod option:

\documentclass[numbers=noendperiod]{scrbook}

\begin{document}

\part{A Part}

\chapter{A Chapter}

\section{A Section}

\begin{figure}
    \centering
    \textit{The contents of the figure go here.}
    \caption{A Figure.}
    \label{Test}
\end{figure}
\end{document}

This produces an output without the additional period.


A related (but non-duplicate) question may be viewed at: KOMA-Script scrbook: How to remove period after part

1
  • Not everywhere, but in the number of any section level (part … subparagraph) and derived numbers. And because figure numbers depend on chapter numbers they also depend on the feature. BTW: Analog to the \partformat in some answers to the referred question, there are also \figureformat and \tableformat.
    – cabohah
    May 26, 2023 at 16:04

Not the answer you're looking for? Browse other questions tagged .