I am using the package libertinus-otf with LuaLatex, MikTeX and the KOMA-Script document class scrartcl. How do I activate Discretionary Ligatures by default for all fonts? I have tried many things as fontscpec's \defaultfontfeatures{Ligatures=Rare}, but nothing seems to work, both for Libertinus Serif and Libertinus Sans, and all of their variants (italic, bold, italic-bold etc.) Here is my minimal working exemple :



\subject{1. affichettes}
\title{2. affichettes}
\subtitle{3. affichettes}
\author{4. affichettes}
\date{5. affichettes}
\publishers{6. affichettes}

7. affichettes

\textsf{8. affichettes}


I am using the french word "affichettes" (little poster) so we can observe easily the discretionary "tt" and "ch" ligatures with the common "ffi" ligature.


Of course, using \Ldlig{affichettes} or \LDLIG+ affichettes everywhere works, but this is not a viable solution. Here is what we should get.

wanted result

1 Answer 1


Seems like when I was using the defaultfeatures option, I put an extra space after the = symbol:

\usepackage[defaultfeatures = {Ligatures = Discretionary}]{libertinus-otf}

Without this extra space, it works:

\usepackage[defaultfeatures ={Ligatures = Discretionary}]{libertinus-otf}

(notice the only difference)

That is a curious behaviour, why is that? Maybe a futur change to this?


  • I am aware of that, I was speaking of discretionary ligatures, the ffi ligature is a common ligature
    – Clzment
    Commented Jun 5, 2023 at 20:37
  • 1
    Ah, Isee. It is a bug, will be fixed ...
    – user187802
    Commented Jun 6, 2023 at 7:29
  • 1
    It is not a problem with libertinus-otf, but a problem with package xkeyval which cannot read the arguments properly. Use \usepackage[defaultfeatures={Ligatures=Discretionary}]{libertinus-otf} without spaces.
    – user187802
    Commented Jun 7, 2023 at 6:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .