0

I’m using footmisc for my footnotes, and using the symbol option. I would like to get rid of the space before the symbol mark, and to have the symbol superscripted in the footnote too:

enter image description here

I couldn’t see anything in the documentation about that, can I achieve that? Minimum working example:

\documentclass[11pt]{book}

\usepackage[paperwidth=11cm,paperheight=18cm]{geometry}
\usepackage[francais]{babel} 

%footnote marks must be symbols and not numbers :
\usepackage[symbol]{footmisc}

\begin{document}
\vspace*{10cm}
This is my main text\footnote{This is my footnote}. 
\end{document}
1
  • 1
    Both of those are due to \usepackage[francais]{babel}, which leads me to believe that they are standard French typographical practice. You should look at the babel documentation to see how to restore to the standard footnote behavior (which is what you want). Jun 15, 2023 at 15:57

1 Answer 1

4

First, please code \usepackage[french]{babel} as recommended instead of \usepackage[francais]{babel}.

Yes, the thin space added is a standard French typographical practice. If you don't like it, you can have a look at the options in the babel-french documentation (file frenchb.pdf in English or frenchb-doc.pdf in French).

\frenchsetup{AutoSpaceFootnotes=false}

will remove the spacebefore the footnote call.

\frenchsetup{FrenchFootnotes=false}

will switch back to the standard footnotes, probably better in your use case. See also the commands \StandardFootnotes and \FrenchFootnotes.

1
  • This solves only the first problem. For the second one you will need \frenchsetup{FrenchFootnotes=false}
    – Ivan
    Jun 15, 2023 at 16:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .