0

I feel I'm lost: For days, if not weeks I'm searching for the cause of a mistake...

I have a document of more than 1000 pages making extensive use of my own macros. Everything works well, till I reach page 596. There, in the second line you find \footnotemark 349. The related \footnotetext starts exactly at the page bottom. With the end of it's first paragraph it reaches the page end, it's second paragraph is placed at the foot of the page before!

I had a similar error before in combination with the environment multicols. And there I had another -- probably related -- error: On one page a \footnotemark plus a lonely \footnoterule at the bottom of the page -- but no \footnotetext, as that only appeared at the bottom of the next page. Frank Mittelbach kindly tried to help, after having transferred my complete sources to him.

He thinks, the problem was somehow caused by LaTeX's page generating algorithm: In the case of the paragraph of \footnotetext on the forepage LaTeX first tries to put the text with \footnotemark and \footnotetext at the bottom of the page, but realizes, that the page thus becomes too long. So it takes back the last two lines with normal text and \footnotemark and places them on the following page. Of course, now it has to take the \footnotetext to the following page as well, as otherwise, the \footnotetext would appear before the \footnotemark -- but something with this process goes wrong, as it only migrates the first paragraph of the footnote, the second one remains on the now wrong page.

Similarly with the "forgotten" \footnoterule: LaTeX tries to set the \footnotetext at the bottom of the page, but fails, as it is too long. So it puts the \footnotetext to the bottom of the following page but forgets to erase the \footnoterule.

This explanation in my eyes still holds for the error on page 596, though this time not in combination with multicols. As the error doesn't seem to be very stable, it meanwhile vanished at the places connected with multicols and now is to be found many pages away at page 596 -- quite far away from any multicol environment (to be honest: The footnote itself contains a multicols environment in the second paragraph, but if I comment out multicols there, the error (fortunately?) remains unchanged). So probably multicols is not to blame.

I have written some macros concerning \footnotes (I had to discard usage of the package footmisc, as years ago it was not compatible with hyperref, now it seems to be, see comment of Ulrike), but meanwhile I had commented out every single of those -- without changing the behavior on page 596.

But as the error appears quite seldom and reacts sensitively to changes in the text even hundreds of pages before my tries to generate an MWE in common ways have completely failed.

I am searching for a way either to build an MWE or haunt down the error myself -- but meanwhile, I feel, I desperately need help. But at the same time, I don't know, whether anyone is able to help me under these conditions.

Edits: Shortened the text.

6
  • 1
    Unrelated but I'm not aware of a incompability of footmisc with hyperref. You can't expect help here for such a general question. Without code nobody can debug this. Apart from this: Check if on the pages or nearby there is something that messes around with the output. multicol is one candidate, but longtable, floats, breakable boxes are possible too. If your system is older check also with a newer one (you can install a new texlive in parallel to your existing system, or try on another computer). Jun 16, 2023 at 14:19
  • I am quite aware of the problem with such a general question, I hesitated for nearly a month before asking ... The log file doesn't show anything suspicious in that area: ------------ Underfull \vbox (badness 10000) has occurred while \output is active [] [593] [594] normal float: set doublelock=false Underfull \vbox (badness 2376) has occurred while \output is active [] [595] [596] -------------------- I updated TeXLive last night to version 2023, but that didn't help. I think, I can exclude multicol, longtable as possible causes -- but not floats ...
    – ThorstenL
    Jun 16, 2023 at 15:30
  • @Ulrike: About footmisc an incompatibilities with hyperref you seem to be right nowadays: When I dropped footmisc (as I was more eager to use hyperref) I noted for myself "Section 2 of footmisc manual: footmisc incompatible with hyperrefs hyperfootnotes option." But that note may well be ten years old and nowadays that incompatibility is not mentioned any longer in the manual -- that problem seems to be solved, but alas doesn't solve my problem.
    – ThorstenL
    Jun 16, 2023 at 15:39
  • 1
    well I think you stop to believe that you can't reduce the problem. This type of problem are typically local, only a few pages matter, at most a chapter. If you use \include, do \includeonly{chapter} and check if the problem is there. Then remove code after the problematic page. Use the option draft to remove the pictures. Jun 16, 2023 at 16:08
  • Are there any floats nearby?
    – Skillmon
    Jun 16, 2023 at 19:53

0

You must log in to answer this question.

Browse other questions tagged .