3

I use TeXShop infrequently (last used it over 6 months ago, probably well over).

I'm on an M1 MacBook Air with MacOS Ventura, 13.4 (22F66).

Today I ran the auto update for TeXShop that was suggested when I launched it. When I attempt to typeset my document, I get an alert "Can't find required tool. <path>/XeLaTeX.engine does not have the executable bit set".

Because I was on TeXLive 2022 I downloaded MaxTeX installer for 2023 and ran that. Same issue. Current version of TeXShop is 5.12.

Here's what's in <path>:

marian@Bajj ~/L/T/Engines> ls -la
total 144
drwxr-xr-x@ 11 marian  staff    352 Oct 22  2022 ./
drwxr-xr-x@ 21 marian  staff    672 Jun 19 05:46 ../
-rw-r--r--@  1 marian  staff    216 Dec  7  2014 ConTeXt (LuaTeX).engine
drwxr-xr-x@ 28 marian  staff    896 Jun 19 05:46 Inactive/
-rw-r--r--@  1 marian  staff    100 Dec  7  2014 LuaLaTeX.engine
-rw-r--r--@  1 marian  staff    100 Dec  7  2014 XeLaTeX.engine
-rw-r--r--@  1 marian  staff     97 Dec  7  2014 XeTeX.engine
-rw-r--r--@  1 marian  staff  22009 Dec  7  2014 nv-metafun.engine
-rw-r--r--@  1 marian  staff  21460 Dec  7  2014 nv-metapost.engine
-rw-r--r--@  1 marian  staff    555 Dec  7  2014 pdflatexmk.engine
-rw-r--r--@  1 marian  staff    557 Dec  7  2014 sepdflatexmk.engine

2014 is kind of old!

I tried moving XeLaTeX.engine aside and symlinking Inactive/XeLaTeX-dev.engine (just for the heck of it, it has a 2019 date on it at least) but had the same issue.

I'm stuck, and I sure hope someone can help me!

1
  • I just remembered something: since the last time I did any typesetting I had to have a warranty repair on my Mac and restored from a Backblaze backup. Perhaps the backup wasn't complete. Is there a way to make a completely clean install of TeXShop?
    – Marian
    Jun 19, 2023 at 13:43

1 Answer 1

5

It's odd that the executable bit is not set. But almost all of the contents of ~/Library/TeXShop will regenerate themselves if deleted. So a simple solution would be to quit TeXShop, move your existing ~/Library/Engines folder to the Desktop and then restart TeXShop. That should regenerate the default engines. If you customized any of your old engines, you can copy them back from the folder you moved to the Desktop.

If for some reason the executable bit is not set on the regenerated engines, you can do the following from the terminal:

chmod +x ~/Library/TeXShop/Engines/*.engine

But I would regenerate the folder as a first choice.

4
  • That worked great! Thanks! In fact, not only are they 755 now, but the date is 3/14/2023. I'm thinking maybe I should just remove the Engines folder when I install a new TeXLive
    – Marian
    Jun 19, 2023 at 17:18
  • Oh! LOL at myself. The error message was "does not have its {executable bit} set" and I was reading it as "does not have its executable bitset". Like somehow it was missing a binary or something.
    – Marian
    Jun 19, 2023 at 17:26
  • @Marian There's no relation to installing a new TeXLive and TeXShop really, except that TeXShop is also distributed with the MacTeX installer. But they're otherwise completely independent of each other. In general you shouldn't really need to do anything with it when you update. The problem you had is certainly not a general one.
    – Alan Munn
    Jun 19, 2023 at 19:53
  • Thanks @Alan, you've been a great help!
    – Marian
    Jun 19, 2023 at 20:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .