I am following tikz tutorial and my code has reached to this point:



\tikzset{Yasser grid/.style={help lines,color=blue!50}}  
    \clip (-0.1,-0.2) rectangle (1.1, .75);  
    \draw [Yasser grid, step=0.5cm] (-1.4,-1.4) grid (1.4,1.4);  
    \draw (-1.5,0) -- (1.5,0);  
    \draw (0,1.5) -- (0,-1.5);  
    \draw (0,0) circle (1cm);  
    \draw (3mm,0mm) arc (0:30:3mm);  

    \shadedraw[left color=gray,right color=green, draw=green!50!black]  
        (0,0) -- (3mm,0mm) arc (0:30:3mm) -- cycle;  
        \draw [red, very thick] (30:1cm) -- +(0, -0.5);  
        \draw [blue, very thick] (30:1cm) ++(0, -0.5) -- (0,0);  
        \draw [green, very thick] (0,0) -- (30:1cm);   
        \draw [orange, very thick] (1,0) -- (30: 1.1547cm);  
        \path [name path=upward line](1,0) -- (1,1);  
        \path [name path=sloped line](0,0) -- (30: 1.5cm);  
        \draw [name intersections={of=upward line and sloped line, by=x}][very thick , orange] (1,0) -- (x);  


I have seen these posts:

I am using TexShop (MacOS) and I followed the instruction in the first post above. Before updating the tikz and after updating it, I am receiving the same error which is similar to the second post above:

Package pgfkeys Error: I do not know the key '/tikz/name path' and I am going to ignore it. Perhaps you misspelled it.

If I comment out the \path command every thing is fine. Am I still not using the latest version of tikz? But I have downloaded the latest version and installed it accordingly. Is there any manual on how to completely remove the tikz and install it in texmf-local instead?

  • This is the exact place I got stuck as well: nowhere, up to this point in the tutorial, do they mention the command usetikzlibrary. – Andriy Drozdyuk Mar 26 '12 at 15:36

You need to load the intersections library:


See 13.3.2 Intersections of Arbitrary Paths in the TikZ 2.10 manual, which explains also name path=... and name intersections=....

| improve this answer | |
  • 1
    Thank you. Unfortunately I have added every thing but that one. There is no comment on tutorial on that. – Yasser Sobhdel Dec 11 '10 at 12:49
  • There is a bug report asking for these instructions to be included in the tutorial – Divinenephron Apr 9 '16 at 11:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.