0


This is my first question and I hope the MWE is working. As visible in the screenshot, the formatting for online sources using the chem-asc style (biblatex) does not work properly and I cannot figure out why. I tried different attempts once splitting the title in {title} and {subtitle} and once only using {title} but it does not change anything.

Furthermore, there should be dots after the author and the title according to the ACS style (highlighted in blue). I cannot figure out how to adapt the style manually.

I already read several posts about biblatex and the chem-acs style but I couldn't find and solution and hope that someone can help me. Thanks already in advance!

enter image description here

\documentclass[a4paper,11pt,oneside]{scrreprt} 
\usepackage[english]{babel}
\usepackage[scaled]{uarial}
\renewcommand*\familydefault{\sfdefault}
\usepackage[T1]{fontenc}

\usepackage{url}
\urlstyle{same}
\usepackage[utf8]{inputenc}
\usepackage[backend=biber,
            style=chem-acs,
            natbib=true, 
            doi=true, 
            hyperref=true,
            giveninits=true,
            pageranges = true,
            articletitle = true,
            autocite=superscript
]{biblatex}
\usepackage{csquotes}

% break URL in biblio:
\setcounter{biburlnumpenalty}{9000}
\setcounter{biburllcpenalty}{9000}
\setcounter{biburlucpenalty}{9000}
     
\addbibresource{QuelleBL.bib}

\begin{document}
 Quelle1\autocite{WasserwirtschaftsamtHof.2018} \\
 Quelle2\autocite{BayrischesLandesamtfurUmwelt.2023} 

\printbibliography
\end{document}

Here is the content of my QuelleBL.bib file:

% This file was created with Citavi 6.10.0.0


@online{BayrischesLandesamtfurUmwelt.2023,
 author = {{Bayerisches Landesamt für Umwelt}},
 year = {2023},
 title = {Gewässerkundlicher Dienst Bayern Abfluss - Gesamtzeitraum Unterzettlitz / Roter Main},
 url = {https://www.gkd.bayern.de/de/fluesse/abfluss/elbe/unterzettlitz-24125006/gesamtzeitraum},
 urldate = {2023-05-28},
 abstract = {}
}


@online{WasserwirtschaftsamtHof.2018,
 author = {{Wasserwirtschaftsamt Hof}},
 year = {2018},
 title = {Ja Main, wo geht's denn hin?},
 url = {https://www.wwa-ho.bayern.de/fluesse_seen/gewaesserportraits/roter-main_lgs/3-main.htm},
 urldate = {2023-05-28},
 abstract = {}
}
1
  • Welcome to TeX.SE!
    – Mensch
    Jul 11, 2023 at 13:41

1 Answer 1

1

The YELLOW issue is hyphenation. You've specified \usepackage[english]{babel}, so LaTeX doesn't know to hyphenate your bibliography which is in German.

You should replace the babel loading with

\usepackage[ngerman,english]{babel}

and add autolang=langname to the options passed to biblatex

\usepackage[backend=biber,
            style=chem-acs,
            natbib=true, 
            doi=true, 
            hyperref=true,
            giveninits=true,
            pageranges = true,
            articletitle = true,
            autocite=superscript,
        autolang=langname
]{biblatex}

and add

hyphenation = {ngerman}

to the bibliography entries that are in German.


The BLUE issue is I think a bug in the biblatex-chem style. The file chem-acs.bbx sets \labelnamepunct to \addspace. The correct one should be \addperiod\addspace. To fix this, immediately after loading biblatex with style=chem-acs, issue

\renewcommand*{\labelnamepunct}{\addperiod\addspace}
2
  • Thank you for your detailed answer! Regarding the yellow issue: Your solution worked perfectly to avoid the overhanging sentence but it unfortunately changed the language of the whole entry, resulting in "zuletzt angesehen am...." instead of "accessed May 28, 2023". I also tried [australian] as a language, which also avoids the overhanging, but also results in the wrong representation of the date (28 May 2023). The only solution which works so far is adding "\break" manually in the .bib file - but that seems like a very poor solution to me. The blue solution works perfectly - thank you!
    – Patricia
    Jul 15, 2023 at 8:54
  • 1
    I suggest asking a separate question on this site about how one can use biblatex to print an entry in a foreign language so that the title obeys the language's hyphenation rule, but the overall formatting of the entry itself is in a different main language of the document. Jul 16, 2023 at 13:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .