1

I am currently working on a project where I have linked Mendeley with Overleaf directly. My problem arises when Mendeley automatically escapes out $ characters, which I need for math mode in my bibliography.

I understand that Overleaf essentially treats the Mendeley-generated BibTeX file as read-only; therefore, I cannot make any changes directly in Overleaf.

I was wondering if there is a way to access the BibTeX file directly and edit it manually, despite it being connected to my Mendeley account (and keeping the changes after the bibliography refreshes of course). I cannot seem to find this option in Mendeley Online and the desktop version is discontinued and thus would prefer not to use it.

Any help or suggestions would be greatly appreciated. Many thanks in advance!

2
  • Welcome to tex.sx. Commented Jul 17, 2023 at 16:07
  • 1
    Reading over this, it looks essentially like a Mendeley issue/feature request, which we can't really help with (sorry). I think you'll need to raise with their support.
    – Joseph Wright
    Commented Jul 18, 2023 at 10:20

1 Answer 1

2

No. By virtue of synchronising with Mendeley, any changes you make would be overwritten on subsequent synchronisations, so even if it is possible to make edits to the bib file (which it makes sense for Overleaf to prevent) this is unwise to rely on.

You either need to fix things on the Mendeley end so it generates an appropriate bib file, or generate a one-off bib file which you can manually upload and edit.

6
  • Is there a way to prevent Mendeley from automatically escaping characters? I can't edit the bib directly on Mendeley either.
    – xan
    Commented Jul 17, 2023 at 16:20
  • @xan - "I can't edit the bib directly". Is something stopping you from opening the bib file in an editor of your choice?
    – Mico
    Commented Jul 17, 2023 at 18:08
  • If I desired that solution, naturally I wouldn't be asking for this.
    – xan
    Commented Jul 18, 2023 at 7:27
  • @xan Apparently Mendeley has had the option to toggle escaping characters, but possibly not any more. Depending on the nature of your references this may cause other/additional problems and appears to apply wholesale to escaping all or no characters. If you need fine-grained control you may need to manually export entries from Mendeley, correct them as appropriate and maintain your own bib file with suitable corrections.
    – Dai Bowen
    Commented Jul 20, 2023 at 17:08
  • I believe Zotero with Better BibTeX offers more fine-grained control.
    – Dai Bowen
    Commented Jul 20, 2023 at 17:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .