2

I have been using org mode on my Manjaro system for more than two years, but after the latest update to the LaTeX repos, I can't seem to export org files to pdf or preview latex fragments.

The error I get whenever I try to preview my LaTeX is:

 org-compile-file: File "/tmp/orgtexNnJFiR.dvi" wasn’t producedPlease
 adjust ‘dvipng’ part of ‘org-preview-latex-process-alist’.

I tried this, didn't work.

I checked basic exporting from org to pdf. I got the error:

! LaTeX Error: File `ulem.sty' not found.

Which is weird, since when I search for the file using pacman -F ulem.sty, I get:

extra/texlive-core 2021.58710-2 (texlive-most)
    usr/share/texmf-dist/tex/generic/ulem/ulem.sty

Did someone experience that?

2
  • Is the file /usr/share/texmf-dist/tex/generic/ulem/ulem.sty there (try ls)? Have you tried, reinstallation of texlive-most resp. texlive-core (maybe the installation is broken for some reason)? I don't use Manjaro. But maybe even try installing texlive-full. Than you should really have everything.
    – cabohah
    Jul 18, 2023 at 8:22
  • The org-mode tag is an emacs thing. But the rest of your post suggests that you're talking about something else. What is org?
    – Teepeemm
    Jul 25, 2023 at 19:05

3 Answers 3

2

Finally fixed it, so posting the solution for other confused org-mode users, here's what i've done to fix this.

My texlive installation originated from the Arch packages. After investigating this, I decided to install it natively.

After some 5 hours of installation and adding the required directories to the PATH, it works like a charm.

1
  • Installing TL natively from TUG is in generally preferable to installing it through a Linux package manager. Besides other problems like yours, the latter are almost never up-to-date versions and might lack newer packages or something similar.
    – lukeflo
    Oct 10, 2023 at 7:12
1

Glad you found a solution. However, I was able to fix it with

sudo pacman -Fy
pacman -F ulem.sty
pamac install texlive-plaingeneric

The first command is important, since the location of ulem.sty has changed, from texlive-core to texlive-plaingeneric. I also upgraded the system before all that, with "pamac update".

Sorry for carelessly mixing pacman and pamac...

1
  • thanks, worked perfectly!
    – xeruf
    Nov 16, 2023 at 20:59
1

On Ubuntu 20.04, I fixed this error by installing package texlive-plain-generic.

sudo apt install texlive-plain-generic

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .