0

Below a mwe:

% !TEX encoding = UTF-8 Unicode
% !TEX program = lualatex
% !BIB program = biber

\begin{filecontents}[overwrite]{\jobname.bib}
@article{a,
  author = {Smith, John},
  title = {Title of the contribution},
  journaltitle = {Journaltitle},
  date = {2000},
}
@article{b,
  author = {Smith, Jack},
  title = {Title of the contribution},
  journaltitle = {Journaltitle},
  date = {2000},
}
\end{filecontents}

\documentclass{article}
\usepackage[style=verbose]{biblatex}
  \addbibresource{\jobname.bib}

\DeclareUniquenameTemplate{
  \namepart[use=true, base=true]{prefix}
  \namepart[base=true]{family}
  \namepart[disambiguation=full]{given}
}

\begin{document}
\autocite{a}
\autocite{b}
\autocite{a}

\printbibliography
\end{document}

enter image description here

As you can see, the short citations are defined without the possibility to disambiguate the labelnames.

Is it possible to find a solution? Thank you

1 Answer 1

0

Name disambiguation is provided by the uniquename option, which the verbose styles don't enable by default. So you have to do that yourself

\documentclass{article}
\usepackage[style=verbose, uniquename=true]{biblatex}

\DeclareUniquenameTemplate{
  \namepart[use=true, base=true]{prefix}
  \namepart[base=true]{family}
  \namepart[disambiguation=full]{given}
}

\begin{filecontents}{\jobname.bib}
@article{a,
  author       = {Smith, John},
  title        = {Title of the contribution},
  journaltitle = {Journaltitle},
  date         = {2000},
}
@article{b,
  author       = {Smith, Jack},
  title        = {Title of the contribution},
  journaltitle = {Journaltitle},
  date         = {2000},
}
\end{filecontents}
\addbibresource{\jobname.bib}

\begin{document}
Lorem\autocite{a}
ipsum\autocite{b}
dolor\autocite{a}

\printbibliography
\end{document}

1 John Smith. “Title of the contribution”. In: Journaltitle (2000).
2 Jack Smith. “Title of the contribution”. In: Journaltitle (2000).
3 John Smith, “Title of the contribution”.

1
  • Thanks, I didn't realize that the uniquename=true option is not set by default (I don't understand why, but maybe it's not that important...)
    – matteofg
    Commented Jul 21, 2023 at 11:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .