12

I am using moderncv to write my CV. Therefore, I want to use a bulleted list withing \cvitem. In principle this works, but an extra line is added so that it is not on the same height as the first argument of \cvitem. Here is an example:

It should look like this:

Language   - first
           - second

But it looks like this:

Language
           - first
           - second

Here is the minimal code

\documentclass[11pt,a4paper,sans]{moderncv}

\moderncvstyle{classic}
\moderncvcolor{orange}   

\firstname{John}
\familyname{Doe}
\begin{document}

\cvitem{test}{
\begin{itemize}
\item some bulleted item
\end{itemize}
}
\end{document}

Thanks for your help.

2
  • BTW, I just noticed, that when I use \cvdoubleitem the problem does not occur.
    – Pascal
    Commented Aug 29, 2012 at 11:35
  • It does not insert the extra space in my system...which version are you using?
    – Bordaigorl
    Commented Jul 31, 2015 at 14:40

4 Answers 4

16

What you are seeing comes from the way the \itemize environment works. If you want to have the first language aligned with the 'Language' entry you have several possibilities:

1) Ignore the bullets completely:

\cvitem{Languages}{first language}
\cvitem{}{second language}

2) Add the bullets manually

\cvitem{Languages}{\listitemsymbol first language}
\cvitem{}{\listitemsymbol second language}

You might also find the \cvlanguage environment useful, as it allows you to describe your language skills, like:

\cvlanguage{english}{advanced}{CAE grade A (2012)}
5
  • 2
    Instead of using $\bullet$, you should rather use the specific moderncv command \listitemsymbol, or the standard latex commands \labelitemi, \labelitemii, etc (depending on the bullet level). This way, you will get the right symbol adjusted to the style you are using, in the right color.
    – Xavier
    Commented Aug 29, 2012 at 13:13
  • Well spotted, I have edited my answer to include this suggestion. Commented Aug 29, 2012 at 14:30
  • I tried to use this solution, but it doesn't work, if the first field (here: languages) is too long and there is a line break. Is there any work around in this case? Compare with this post: tex.stackexchange.com/questions/181223/…
    – Mil
    Commented May 30, 2014 at 18:03
  • @Mil, nope, I think the only option would be to make the first column wider, by putting in preamble something like \setlength{\hintscolumnwidth}{2.5cm} Commented Aug 6, 2014 at 7:22
  • 1
    Instead of using a new cvitem, go to a new line with \newline. This also allow to make bulleted lists when in place of "language" you have a label that spans multiple lines "languages i would like to know". with the suggested method, the second bullet will go down.
    – Gianni
    Commented Oct 3, 2020 at 7:18
2

Use \cvlistitem{} after the CV entry as the next command. worked for me.

\cventry{2016-Ongoing}{Finding alien life}{}{}{}{}
\cvlistitem{found one on earth}
\cvlistitem{searching in ...}
1

It is due to the package enumitem. If you disable \usepackage{enumitem}, then the extra line disappears as it works in template.tex of moderncv.

2
  • There is no \usepackage{enumitem} in the code in question. Do you suggest to modify the moderncv class? Commented Jul 31, 2015 at 13:25
  • Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. Commented Jul 31, 2015 at 13:26
0

In my case, the simple:

\cvitem{ABD}{
  \begin{itemize}
    \item DEF
    \item IJK
  \end{itemize}
}

Worked as expected:

enter image description here

However, I had troubles to add newline inside the item. However, creating a wrapping minipage (top centered) solved the problem:

\cvitem{ABD}{
  \begin{minipage}[t]{1.0\linewidth}
    \begin{itemize}
      \item DEF\\
            IJK
      \item IJK
    \end{itemize}
  \end{minipage}
}

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .