3

On my local machine, running TeXLive 2022 I can get the following code to work just fine

\documentclass[ a4paper
              , onecolumn
              , superscriptaddress
              , 10pt
              % , draft
              , accepted=2022-02-14
              , issue=6
              , volume=5
              , shorttitle=papers/compositionality-5-6
              ]{compositionalityarticle}
\pdfoutput=1

\usepackage{hyperref}

\begin{document}
\title{Xxxxxxxxxxxxx xxxxx-xxxxx xxxxxxxx xxx xxx xxxxxxxx xxxxxxxxx xxxxx xxx xxxxxxxxxx}
\maketitle
\end{document}

where compositionalityarticle.cls is available from this GitHub repo (and one needs this image to avoid an error). In testing this on the arXiv's current setup (TeXLive 2023), the title does not line-wrap.

However, if I uncomment the draft option, then the arXiv's TeX engine gives the intended behaviour.

The piece of the .cls file that handles making the title contains the following commands, which I hope is enough for people to see what might be going wrong:

%title
\def\@printtitle{%
{%
        \iftoggle{@unpublished}%
        {%
            \@printtitletextwithappropriatefontsize%
        }%
        {%
            \edef\@titleexpanded{\detokenize\expandafter{\@title}}%
            \iftoggle{@xstring}%
                {\saveexploremode\exploregroups\StrSubstitute{\@titleexpanded}{ }{\%20}[\@titleforurl]\restoreexploremode}%
                {\gdef\@titleforurl{\@titleexpanded}}%
              \href{https://compositionality-journal.org/\@shorttitle/}
              {%
                    \color{compositionalitypink}{%
                                              \@printtitletextwithappropriatefontsize\unskip%
                    }%
                                          }%
        }%
    }%
}

and

\def\@maketitle{%
\sffamily
\null
\let \footnote \thanks
\noindent%
\begin{minipage}{\textwidth}%
      \iftoggle{@titlepage}{\centering}{}%
      \noindent{\huge\hyphenpenalty=5000 \@printtitle\par}%
    \end{minipage}%
\vskip 1.5em%
\noindent\@printauthors
\vskip 1em%
\noindent\@printaffiliations
\vskip 0em%
\ifdefempty{\@date}{}{\noindent{\footnotesize\color{compositionalitygray}\@date}}%
\par
\vskip 1.5em
\makeatletter%
\begingroup
\hypersetup{%
    pdftitle={\detokenize\expandafter{\@title}},
    pdfauthor={\@authorsonly},
    pdfkeywords={\@keywords},
    pdfcreator={LaTeX with hyperref package and class compositionalityarticle \csname [email protected]\endcsname},
}%
\endgroup
\makeatother%
}

Here's something from the log in the broken compile:

(./compositionality_test.out) (./compositionality_test.out)
Underfull \hbox (badness 10000) in paragraph at lines 21--21
[]\OT1/lmss/m/n/24.88 Xxxxxxxxxxxxx xxxxx-xxxxx xxxxxxxx

Underfull \hbox (badness 2229) in paragraph at lines 21--21
\OT1/lmss/m/n/24.88 xxx xxx xxxxxxxx xxxxxxxxx xxxxx xxx

Underfull \hbox (badness 10000) in paragraph at lines 21--21
[]\OT1/lmss/m/n/20.74 Xxxxxxxxxxxxx xxxxx-xxxxx xxxxxxxx xxx xxx

Overfull \hbox (286.71513pt too wide) in paragraph at lines 21--21
[][][][][][] 

but here's the corresponding part of the working compile on my machine

\@titelsaveboxHuge=\box54

Underfull \hbox (badness 10000) in paragraph at lines 18--18
[]\OT1/lmss/m/n/24.88 Xxxxxxxxxxxxx xxxxx-xxxxx xxxxxxxx
 []


Underfull \hbox (badness 2229) in paragraph at lines 18--18
\OT1/lmss/m/n/24.88 xxx xxx xxxxxxxx xxxxxxxxx xxxxx xxx
 []

\@titelsaveboxHugeoneline=\box55
\@titelsaveboxhhuge=\box56

Underfull \hbox (badness 10000) in paragraph at lines 18--18
[]\OT1/lmss/m/n/20.74 Xxxxxxxxxxxxx xxxxx-xxxxx xxxxxxxx xxx xxx
 []


Underfull \hbox (badness 10000) in paragraph at lines 18--18
[][][]\OT1/lmss/m/n/20.74 Xxxxxxxxxxxxx xxxxx-xxxxx xxxxxxxx xxx xxx
 []

It might be these are useful to see what is going on.

5
  • I should remark that I can't go and install TeXLive 2023 just now, to test if it's that, or something else. Aug 9, 2023 at 2:50
  • Imho arxiv wants to find the pdfoutput=1 in the first 5 lines, and you have to many options and so arxiv is not correctly switching to pdflatex and so the links no longer break. Add the \pdfoutput=1 before the class and use in the class options nopdfoutputerror. (Imho the class is trying to be too clever with its all arxiv detection code). Aug 9, 2023 at 10:44
  • @UlrikeFischer thanks! I'll pass that back to the journal. Aug 9, 2023 at 10:56
  • That's certainly a way of listing args Aug 9, 2023 at 17:58
  • @AzorAhai-him- 'twas the journal technical editor that formatted it thus Aug 9, 2023 at 19:48

1 Answer 1

6

Imho arxiv wants to find the \pdfoutput=1 in the first 5 lines and in your document it is too late as you have too many class options. This means that arxiv is not correctly switching to pdflatex and the links can't break.

Add the \pdfoutput=1 before the class and use in the class options nopdfoutputerror to avoid that it reverts the settings again.

(Imho the class is trying to be too clever with all its arxiv detection code and options. And arxiv should offer a proper option to select the engine.).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .