I tried to make pdf from Doxygen latex file refman.tex. The Doxywizard finished successfully. Then I opened the refman.tex, choose "pdfLaTex+MakeIndex+BibTex" and run it to get the pdf. Unfortunately, it ended up with the following message:

Sorry, but "MiKTeX Compiler Driver" did not succeed.

The log file hopefully contains the information to get MiKTeX going again:


The texify.log contains the following message:

2023-08-10 09:46:58,666+0200 FATAL texify.core - TeX engine failed for some reason (see log file).
2023-08-10 09:46:58,666+0200 FATAL texify.core - Data: 
2023-08-10 09:46:58,666+0200 FATAL texify.core - Source: Programs\MiKTeX\texify\mcd.cpp:1564
2023-08-10 09:46:58,714+0200 FATAL texify - TeX engine failed for some reason (see log file).
2023-08-10 09:46:58,714+0200 FATAL texify - Info: 
2023-08-10 09:46:58,714+0200 FATAL texify - Source: Programs\MiKTeX\texify\mcd.cpp
2023-08-10 09:46:58,714+0200 FATAL texify - Line: 1564

I tried to search the mcd.cpp file, but unfortunately was not able to. There is no texify folder in MiKTeX folder.

How to solve this issue?

For your information, I succeded once to generate pdf file after installing some recommended packages but after that when I tried to made some changes in the DOXYWIZERD to see the resulted output, it failed always. Also, I tried to run in the cmd:

pdflatex refman.tex

It is now generating a pdf but without the page number in the index.

pdf output index without pagenumber

Could anyone help me to solve this problem?

Thank you in advance for your time and effort.

  • Actually this question is a duplicate of: stackoverflow.com/questions/76874425/…
    – albert
    Aug 10 at 10:26
  • Which version of doxygen / doxywizard are you using? Which settings did you use different from the default settings (result of doxygen -x Doxyfile or in the doxywizard in the run tab the results of "show configuration" with the "condensed button set? Can you share the a small example showing the problem? Which version of MiKTeX did you use? Did you try to run "make" on the doxygen generated latex directory.
    – albert
    Aug 10 at 10:27
  • 1
    do not use texify if you get errors. Its error messages are quite useless. (Personally I wouldn't use texify at all but other tools like latexmk or arara) Aug 10 at 10:33
  • @albert, I asked the same question in the stackoverflow also. First I posted there. Then I thought, this group is more specific and may be I can reach to different audience. Should I delete one? Aug 10 at 14:00
  • It is not yet clear where the problem lies especially as there is no answer to the question "did you try to run "make" on the doxygen generated latex directory." with the other question. For the time being I think it is better to delete this question and provide the results in the original question and its comments.
    – albert
    Aug 10 at 15:55


You must log in to answer this question.

Browse other questions tagged .