I have specified the right, left, top and bottom margins in the Lyx settings under Page margins, but the page numbers appear outside those margins. How can I force the page numbers to be within the margins?

Many thanks in advance!

closed as too localized by Torbjørn T., Joseph Wright Oct 6 '12 at 22:24

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Welcome to TeX.sx! Are you, apart from the margins, using the default layout? Try adding includefoot to the custom class options, in Document --> Settings --> Document class. – Torbjørn T. Aug 29 '12 at 18:23
  • Thanks a lot for your prompt reply!!! Yes, I am using the default layout (I think...: document class: article, and in Class options, the Predifined grey box is ticked). However, when I put " Custom: includefoot ", I cannot compile the doc into pdf anymore. It reports hundreds of errors (eg too many unprocessed floats, undefined control sequence, etc). Shall I add includefoot somewhere else? Many thanks in advance. – Laure Aug 30 '12 at 9:33
  • Hard/impossible to say what causes this without more information. Can you create a sample LyX file with the exact same settings as your original file, so that the problem is seen, but with the contents replaced by some filler text? Having done that, open the .lyx file in a text editor (e.g. Notepad), copy the entire contents of the file (it's just text) and edit your question to include this. – Torbjørn T. Aug 30 '12 at 11:28