2

I'm trying to compile a document which needs the package minted, but it throws the same error over and over:

! Package minted Error: You must have `pygmentize' installed to use this package

I can't seem to make it work. Other forums say to install the package "Pygments," which is a Python package, but MikTeX doesn't seem to have that package in its repositories. Am I missing something? Do I have to install another LaTeX motor or something?

Edit:

Before anybody asks, yes I'm using the "-shell-escape" flag to compile the document which minted requieres.

2

1 Answer 1

0

All right, so as it turns out, minted is a package that requieres Python installed with the package "Pygments" included. I happen to use Anaconda for python, so I had to modify the "Path" variable to include the installation directory of Anaconda, and using the Anaconda Navigator, I used the command:

conda install -c anaconda pygments

And then also

pip install Pygments

which for some reason seemed to work. However after that, I also had to include the directory of the "Pygments" package in the "Path" variable (C:/.../Anaconda/Scripts) and set is as high priority (above the rest of the Paths that execute LaTeX), and then restart the computer. Done that, the package minted finally worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .