1

I am writing a document in markdown with inline citations [@ref]. References are stored in a separate biblatex file managed with betterbibtex and zotero.

I am then using pandoc to render this to PDF output (via LaTeX). I am using a publicly available template (https://github.com/Wandmalfarbe/pandoc-latex-template). I have modified it but I have tested everything below with an unmodified version.

It has been working absolutely fine rendering the document nicely. No changes to the template and it has stopped working and produces an error:

! Undefined control sequence.
<argument> ...size \sf@size \selectfont \citeproc 
                                                  {ref-ref1}{1}, \ci...
l.581 \citeproc{ref-ref2{2}}

Mac OS X - Up to date

Pandoc v3.1.7

Mactex last update March 2023

I have tested and pandoc can still render a docx without issue.

I can still render a PDF in latex without the template

I have not changed the template.

I have also tried running this on a basic test.md which contained minimal text and a single reference. Works without template as soon as I add template no luck.

I have asked it to render to .tex and had a look at the code it produces and can't find anything odd. Although I've not worked out quite how citeproc defines the /citeproc command as in my experience with LaTeX (limited) this happens when a command hasn't been defined or a package hasn't been loaded.

I think I can reasonably assume that I have isolated the problem to the template. However, I cannot:

a. see how to fix it or

b. Understand why the issue has suddenly cropped up

My understanding is that with v3.1.6 and 3.1.7 there have been some changes on how templates interact. If that's the case anyone have any suggestions on what may need to be changed or any workaround I could try?

5
  • Please clarify your specific problem or provide additional details to highlight exactly what you need. As it's currently written, it's hard to tell exactly what you're asking.
    – Community Bot
    Commented Sep 5, 2023 at 15:28
  • pandoc 3.1.7 changed the template, you can find the relevant code here: github.com/jgm/pandoc/issues/9031#issuecomment-1694744040
    – DG'
    Commented Sep 5, 2023 at 15:47
  • 1
    @DG thanks! Found and fixed
    – airj
    Commented Sep 5, 2023 at 15:49
  • X-post stackoverflow.com/q/77045419/2777074 Commented Sep 5, 2023 at 16:00
  • If you cross-post the same question on multiple sites, you should include links to all other versions of the question in every question. X-posting without explicit links has the risk of wasting both the time of users who might put time and effort into answering a post, which already has an answer elsewhere, as well as the time of users who might have the same problem but can't find the solutions you might have gotten on one of the other sites you x-posted your question Commented Sep 5, 2023 at 16:00

2 Answers 2

1

ANSWER: Pandocs updated their default template in v3.1.7 which changed how they define the command.

Found the tracked changes to default.latex on their github and updated the template. Works again.

3
  • You could open an issue for the Eisvogel template
    – DG'
    Commented Sep 5, 2023 at 15:51
  • 1
    As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Commented Sep 5, 2023 at 16:38
  • @airj could you please let us know how exactly you fixed your issue?
    – universvm
    Commented Apr 30 at 8:23
0

for those landing here, the answer is in https://github.com/Zettlr/Zettlr/issues/4879 replace your current code inside $if(csl-refs)$ to $endif$ with the code posted here "Alexandros81 commented on Feb 8"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .