I am able to add the figure in a lyx document, by using float and insert graphics. But when I view in the pdf, I don't see the figure in the inserted location. Instead I see the location of the file inside a blank box. See below.

enter image description here

I want to know why this is the case and any suggestions on how to fix it

  • 2
    normally it means that you have somewhere a draft option, or the pictures are not found, check the log-file. Sep 5 at 20:10
  • 1
    Welcome to TeX.SE. I'll echo the request to check the log file. But that file name almost looks like an absolute path /Users/muthukum.../Documents//Thesis/Muthu/thesis/fig1_1.pdf that got mangled in the conversion process. Is that possible?
    – Teepeemm
    Sep 5 at 20:17
  • These are line in the log-file "<fig1_1.pdf, id=22, 496.85625pt x 289.08pt> LaTeX Font Info: Trying to load font information for T1+cmtt on input line 1 59. (/usr/local/texlive/2023/texmf-dist/tex/latex/base/t1cmtt.fd File: t1cmtt.fd 2022/07/10 v2.5l Standard LaTeX font definitions ) [5 {/usr/local/texlive/2023/texmf-dist/fonts/enc/dvips/cm-super/cm-super-t1.enc}] <6_Users_muthukumaranpanchaksaram_Documents__Thesis_Muthu_thesis_fig1_1.pdf, id =29, 496.85625pt x 289.08pt>" Sep 5 at 21:37
  • Also, in the log file I see that the draft mode is true. Should I change it to 'false' Sep 5 at 21:40
  • You should be able to remove draft from \documentclass[...]. final is the default option.
    – Teepeemm
    Sep 5 at 22:19

1 Answer 1


Most probably you have checked by error the Draft mode in the LaTeX and LyX options tab of the Graphics dialog:


You can check also if the image have this option in the Code Preview Pane, (View menu):


Maybe you have set the option at a document level:


And then you must see in the Code Preview Pane some starting code as:


Improbably, you could have this global option in the graphicx package, because set this is not trivial with LyX menus: Document → Settings → Local layout → type provides graphicx 1 → Validate → Apply, then in LaTeX preamble → type → \usepackage[draft]{graphicx} → Apply.

Finally, if there are not any draft option anywhere, but the image is not still showed the PDF, the file does not exist, or you set the wrong path and/or the wrong filename.

At this respect, just some suggestions to debug this kind of issues:

  • Place the images in the working directory.

  • Be sure that you do not set absolute paths (C:\etc\etc...) in the Graphics tab, but only relative paths (if you follow the above point, the relative path is just the file name).

  • Use short and simple file names (No spaces, no underscores, no extra dots, no tildes, no mix under-upper cases, no nothing). Although actual programs supposedly can handle well all of this, live is simply easier without having to deal with hypertrophied file names.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .