1

when I compile the latex project, shows error:

! Package fontspec Error: The font "標楷體" cannot be found.

I have already put the font 標楷體.ttf to system folder /usr/share/fonts/ in linux, why still could not found the font? This is how I set the font:

\setCJKmainfont[AutoFakeBold=true,AutoFakeSlant=true]{標楷體}

this is the font path:

/usr/share/fonts/zh/tw # ls -alh
total 10M
drwxr-xr-x    2 root     root        4.0K Oct 10 10:32 .
drwxr-xr-x    9 root     root        4.0K Oct 10 10:31 ..
-rw-r--r--    1 root     root        9.9M Oct 10 10:32 標楷體.ttf

Am I missing something? what should I do to fixed this issue? I can see the font like this:

/usr/share/fonts/zh/tw # fc-list|grep "標楷體"
/usr/share/fonts/zh/tw/標楷體.ttf: AR PL KaitiM Big5,文鼎PL中楷:style=Regular

I have tried to copy the fonts to these folder:

~/.fonts/
working folder
/opt/texlive/2023/texmf-dist/fonts/truetype/

still could not found. I can found the fonts:

/usr/share/fonts/zh/tw # fc-list|grep "標楷體"
/root/.fonts/標楷體.ttf: AR PL KaitiM Big5,文鼎PL中楷:style=Regular
/usr/share/fonts/zh/tw/標楷體.ttf: AR PL KaitiM Big5,文鼎PL中楷:style=Regular
/opt/texlive/2023/texmf-dist/fonts/opentype/標楷體.ttf: AR PL KaitiM Big5,文鼎PL中楷:style=Regular
7
  • 1
    Are you sure that /usr/share/fonts/zh/tw is one of the folders searched by fontspec? Have you tried specifying an explicit path option?
    – Mico
    Oct 10, 2023 at 12:26
  • yes, I am sure the path is the search path because I put all the misssing fonts in the folder /usr/share/fonts , all works fine except the 標楷體.ttf.
    – Dolphin
    Oct 10, 2023 at 12:34
  • have you re-run fc-cache since adding the font? Oct 10, 2023 at 12:48
  • yes, I have already run fc-cache .
    – Dolphin
    Oct 10, 2023 at 12:50
  • 2
    Not only TeX, but also I would have a problem finding a font with such a name.
    – wipet
    Oct 10, 2023 at 13:32

1 Answer 1

1

Finally I found the font name is not 標楷體, using this command to check the font name:

/app # fc-list :lang=zh-tw|grep "標楷體"
/usr/share/fonts/zh/tw/標楷體.ttf: AR PL KaitiM Big5,文鼎PL中楷:style=Regular

the font name is AR PL KaitiM Big5.

2
  • 1
    Problem solved. But: I wonder why the system identified the font by its CJK characters, rather than by its Latin character name? This suggests that different encodings are used. A mystery.
    – rallg
    Oct 10, 2023 at 17:37
  • 1
    the font full name should be R PL KaitiM Big5,文鼎PL中楷, but I could not use the R PL KaitiM Big5,文鼎PL中楷. it also told could not be found. the name make me confusing. The latin name works.
    – Dolphin
    Oct 11, 2023 at 5:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .