0

so I'm having a recurring issue while trying to install TeX Live on my Windows 11 system and am hoping to find some assistance here. A similar issue was had by 'TeX Live Installation Failure on Windows' though there is no answer and I don't understand the comment.

Background

So I had TeX Live, as a physics/maths student it's like part of my everyday writing out my assignments, and I use markdown Mathjax for my notes. While making a R Markdown Stats Assignment, I was having issues knitting to PDF with TeX Live, so I updated the packages with the terminal, still had issues to I knitted to html instead. But when I went back to VSCode for LaTeX, I couldn't make it compile, I was encountering persistent issues primarily related to l3backend-pdftex.def with errors such as "Undefined control sequence" and issues with macro parameter characters and issues with an update or package inconsistency in my TeX Live distribution.

Issue Description:

So I decided to reinstall. I couldn't find the program in the control panel, so I deleted the file in C, and checked there wasn't anything Tex-related in PATH in the Environment Variables in System Properties. Then I rebooted. I downloaded install-tl-windows (1).exe from the website, (1) because I had it before from last time (deleted now). During the installation of TeX Live, the process consistently fails with error messages related to permission denial and an inability to create certain files (e.g., luaharfbuzz.pdf, pubring.gpg). The log suggests that tar is unable to create these files due to permission issues. However I run the executable as an administrator. Screenshots are attached at the end.

Error Messages: Some of the notable error messages include:

  • tar: Could not create file texmf- dist/doc/luatex/base/graphics/luaharfbuzz.pdf: Permission denied
  • tar: Could not create file tlpkg/gpg/pubring.gpg: Permission denied
  • TLPDB: :_install_data: untar failed for https://mirror.aarnet.edu.au/pub/CTAN/systems/texlive/tlnet/archive/luatex.doc.tar.xz

Troubleshooting Steps Taken:

  1. Adjusting Permissions: I have attempted to resolve the permission issues by running the installer as an administrator, which changed nothing.
  2. Safe Mode Installation: Tried installing TeX Live in Safe Mode, but encountered network issues due to the seeming lack of internet access in Safe Mode lol.
  3. Changing Code Pages: I modified the system locale (code page settings for non-Unicode programs) and attempted the installation again, without success.
  4. Reinstallation Attempts: I've tried to reinstall TeX Live multiple times, ensuring that any potentially conflicting older versions were removed in C and checking that there wasn't anything TeX related in PATH again beforehand.

System Information: Operating System: Windows 11 Installation Path: C:/texlive/2023 Installer Version: install-tl-20231013

I am attaching screenshots from the installation process to provide a clearer overview of the encountered issues.

Apologies if something similar has been resolved before, and I would appreciate guidance to that because I don't really know what I'm doing - I'm a physics student mostly so I have just a little bit of an idea about everything.

Any guidance or suggestions on how to successfully install TeX Live without encountering these issues would be immensely appreciated. Thank you in advance for your time and assistance.

enter image description here

4
  • Welcome to TeX.SE!
    – Mensch
    Commented Oct 14, 2023 at 9:59
  • well your first error probably only meant that you needed to recreate the format (or perhaps update a package), but now things are difficult. You could try to find the pdf which is blocked and try to delete it first. Commented Oct 14, 2023 at 10:25
  • i updated all of my packages, which seems to be what caused the issue? what do you mean find the pdf which is blocked? Which of the errors indicates that?
    – HarryB
    Commented Oct 14, 2023 at 11:17
  • You can pass --keep to the exe installer and that should leave the unpacked files in a temporary directory. Basically what happens is that the .exe installer contains the same stuff as the .zip plus the self-extraction code, so there shouldn't be much of a difference.
    – norbert
    Commented Jan 11 at 0:07

2 Answers 2

0

Got the same problem. Maybe you got the setup exe from the link in this page https://tug.org/texlive/windows.html, same as me. The exe downloaded from that link didn't work. Later I downloaded another setup package from this link http://mirror.ctan.org/systems/texlive/tlnet/install-tl.zip, unpacked the zip, ran the bat file and the errors were gone.

2
  • welcome to tex.sx. Commented Jan 10 at 23:28
  • The last line in the screenshot lists a path .../install-tl-20231013/install-tl. This proves that the exe is out of date.
    – Siep
    Commented Jan 12 at 9:39
0

I had the same experience; it seemed like an administrator permission issue.

Here's what I did:

  1. Chose 'unpack only' to unzip the files to the desktop.
  2. Go to the unzipped folder (install-tl-today's date).
  3. Run 'install-tl-windows.bat' as an administrator.

Doing this solved the problem!

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .