0

I am having a strange problem with the "Document class" option in Lyx. Up until now, all document classes showed as "unavailable". Nonetheless, when I viewed documents as PDFs, they appeared as the standard article class. I wanted to try more document classes, so I read this thread, and followed these steps:

  • Copy the files in C:/Program Files (x86)//Resources/layouts/
  • Paste the files into C:/Users//AppData/Roaming//layouts/
  • In command prompt, run texhash
  • Then, in LyX click Tools > Reconfigure; when finished restart LyX.

The document classes now show as available, but something has gone seriously wrong! I have attached a screenshot of how my PDF appears when using the standard article class. The text appears wobbly and nothing like the standard article class that I am used to.

I am using all default settings. Things I have already tried:

  • Uninstalling and reinstalling Lyx
  • Updating all packages in MikTex console and reconfiguring Lyx
  • Changing to many different document classes

None of these made any difference to the problem. Any advice would be much appreciated! enter image description here

13
  • Although I cannot answer the question, I see the "all wobbly" text in the image. In general, that is caused when the font outlines do not correspond to some font metrics, or there are bad font hints, or the font (if OpenType) has a bad internal private dictionary. Can you clear the font cache, however that is done for your system, and try again? What engine are you using, and what kind of fonts?
    – rallg
    Oct 16, 2023 at 17:41
  • Thanks for your reply. I just tried clearing the font cache, and I reconfigured Lyx after (not sure if that is necessary). However the problem persists. Re the type of fonts I am using, I'm not too sure. I just have all default options selected for the standard article class. p.s. It was font related after all, so thanks for pointing me in the right direction! Oct 17, 2023 at 8:10
  • 4
    I’m voting to close this question because reading the OPs own answer it was solved by a change in the Lyx-specific settings.
    – MS-SPO
    Oct 17, 2023 at 8:25
  • Maybe you are missing the cm-super package.
    – Udi Fogiel
    Oct 17, 2023 at 10:02
  • @MS-SPO, this is probably not related to a LyX-specific setting, it is just that this checkbox switch the compiler, and thus the default fonts. The problem is probably with the 8-bit fonts he has on his system.
    – Udi Fogiel
    Oct 17, 2023 at 10:05

1 Answer 1

1

Going to the Document tab -> settings -> fonts, and checking the box "Use non-TeX fonts" seemed to solve the problem. Not sure why this is. I suppose I am using non-TeX fonts without meaning to :)

2
  • 1
    Well done, Isaac
    – MS-SPO
    Oct 17, 2023 at 8:25
  • This doesn't really solve the problem if you want to use pdfLaTeX. You just switched from compiling with pdfTeX, to XeTeX, and XeLaTeX use different fonts by default.
    – Udi Fogiel
    Oct 17, 2023 at 10:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .