I am writing a presentation (beamer class) in MiKTex and for some reason I need to use the tgbonum typeface. The issue is that I am unable to generate bold text. Actually, I do receive the following warning message, which indeed informs the user that all bold text is converted to normal.

LaTeX Font Warning: Font shape `OT1/cmss/b/n' undefined, using OT1/cmss/b/n instead.

I am aware of some solutions, as for example to use the lmodern package, however this is not an option for me, since it affects spacing of existing content and many things get messed up.....

The strange thing is that this problem appears to me only with MikTex (which I'm using, actually I'm prety new to LaTeX at all). Parsing the same code in overleaf, produces the desired outcome (i.e. \textbf{} text appears as bold). But I do not want to use overleaf since my project is large enough and I need to pay for getting extra compile time, which I cannot afford to.

Below is a sample text code (not related with my project) in which one may easily locate the problem. May you copy it to a MikTex distribution and overleaf you get different results (overleaf for some reasons performs better here).

Does anybody know why this is happening, why do MiKTex and overleaf behave differently and most important of all, how I could possibly fix this issue in MiKTex? I appreciate for your help.


p.s. Commented-out lines indicate some options I've tried to, unfortunately with no success :(

sample code








\title{Sample title}



\frametitle{Sample frame title}

The text below should appear in bold. It does in overleaf, however it fails to in MikTex.

\textbf{This is some text to appear in bold}

\alert{This is an alert message; should also appear in bold in this ''theme/color'' combination}


  • 1
    I can't help, but that message, "Font shape `OT1/cmss/b/n' undefined, using OT1/cmss/b/n instead." is very peculiar. I've never seen such a message with both font specifiers identical as you've shown. Are you certain you copied it correctly? Nov 12 at 21:51
  • 1
    works fine for me. Show the log-file of your MWE. Nov 12 at 21:57
  • \usepackage{tgbonum} does nothing by itself in beamer. You need to add \usefonttheme{serif}.
    – egreg
    Nov 12 at 22:17


You must log in to answer this question.

Browse other questions tagged .