4

I am trying to port some app from MikTex to TexLive (Windows to Ubuntu basically). The options that works perfectly fine with MikTex just ended up as not recognized for TexLive

The options in question are 'include-directory' and 'aux-directory' for XeLatex. Tried the default TexLive 2009 of Ubuntu as well as the latest TexLive 2012 - same result as below:

/usr/local/texlive/2012/bin/x86_64-linux/xelatex: unrecognized option '-aux-directory=/home/user/Desktop/Tex/Aux_sample3_MT2886/'
/usr/local/texlive/2012/bin/x86_64-linux/xelatex: unrecognized option '-include-directory=/mnt/host/WinApp/CarMusTy/bin/template'
/usr/local/texlive/2012/bin/x86_64-linux/xelatex: unrecognized option '-include-directory=/mnt/host/WinApp/CarMusTy/src/res/fonts/wip'
This is XeTeX, Version 3.1415926-2.4-0.9998 (TeX Live 2012)

No difference if -aux-directory or --aux-directory. And the 'xetex -- help' command does not show those options either.

Wondering if these are MikTex specific options or if I am missing something.

Help is appreciated.

Thank you.

ps: For those curious, this is happening in the CarMusTy application while building the generated tex files on ubuntu (which works perfectly fine on Windows with MikTex, though)

7
  • The option is --output-directory=...
    – egreg
    Sep 6 '12 at 13:31
  • I'm seeing these options the first time, so I am pretty pretty sure they are MikTeX specific. What is their semantics?
    – norbert
    Sep 6 '12 at 13:38
  • Yes, I am using 'output-directory' option for the generated pdf location and it is recognized fine. But I have few dependent style files that need to be gathered from an app-specific location, which was being specified by 'include-directory'. All my tex files will refer that common 'include' location (while 'output' location of each of them will be different). How to simulate this 'include-directory' thing with TexLive?? Sep 6 '12 at 13:39
  • 2
    For the include directive, use TEXINPUTS=...: xelatex, for the auxfile there is no solution AFAIK, unless you want all output files in that directory.
    – norbert
    Sep 6 '12 at 14:32
  • 1
    Thanks Norbert. Seems TEXINPUTS is an env.variable. I would have preferred a command line option, but thats ok, I can try set this env.variable per-process while xelatexing. I did not know about this env. var. I did a search after you mentioned it and found this: Tex Search Paths Sharing it here for any who wants to know. Something like ending TEXINPUTS with colons will prepend the path etc... Sep 7 '12 at 1:40
13

Yes, -aux-directory and -include-directory are specific to MikTeX. web2c/kpathsea-programs (e.g. those from TeXLive) offer only -output-directory.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.