0

started learning lyx this week for university, to familiarize myself with the program I've written a document that explains everything as I go, trying to understand everything I might use. there's a small Facebook group for my language (Hebrew) where I got a useful shortcut file as well as a macros file. everything worked great just up to yesterday but then I tried to compile again my file to see how it looked and was faced with the following error screen: the error highlights a macro called kaliForm (which I don't know its function) and says the title is missing and gibberish description

where in my document I don't even use this macro or any macros. I've asked in the Facebook group as well as in the LaTeX subreddit and got no answers so far. here's the compute log from the error: say's here as well that no title given

I don't know why but creating a "layout author" causes this error saying "no \title given" so any ideas on how to solve it and what caused this problem in the first place would be helpful, thanks in advance

1
  • Welcome to TeX.SE!
    – Mensch
    Commented Dec 21, 2023 at 23:00

1 Answer 1

0

You have an author field, which cause LyX to think you have a title, thus it adds \maketitle at the beginning of the document. Using \maketitle without specifying a title cause this error.

Either add a title to your document, or add the following to Document->settings->Local Layout

Style Author
    InTitle               0
End

although I'm not sure how the second approach will help you practically.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .