Steps to Reproduce

  1. Installing overleaf community edition using the toolkit and successfully pulling every Texlive package via tlmgr install scheme-full
  2. Exporting the kaobook-Template from overleaf.com after importing it from here
  3. Compiling the files from scratch after clearing the cache

Expected Behaviour

Successful compilation of a PDF file including correct references and bibliography The same LaTex project compiles without major errors on overleaf.com

Observed Behaviour

The references and the bibliography aren't generated properly When compiling i get the following persistent errors:

Package hyperref Warning: bookmark level for unknown mtocsection defaults to 0.

Citation 'XXX' on page 1 undefined on input line X ...for very citation

Empty bibliography on input line 258.

Package biblatex Warning: Please (re)run Biber on the file: output and rerun LaTeX afterwards.

I'll attach the raw log file.

Probably the community edition doesn't use or supporting the compileall.sh file of the package that specifies how to compile the document. I'll paste it here:


# Compile document
pdflatex -interaction=nonstopmode main

# Compile nomenclature
makeindex main.nlo -s nomencl.ist -o main.nls

# Compile index
makeindex main

# Compile bibliography
biber main

# Compile document
pdflatex main

# Compile glossary
makeglossaries main

# Compile document
pdflatex main

Technical Info

Beside this error the installation works well. The /bin/doctor script included in the toolkit doesn't show any errors

Thank you in advance for your help!

  • If you run the compile steps manually (especially biber and then pdflatex again), does it work? If you try a simple document with the article documentclass and one citation, does it work?
    – Marijn
    Commented Jan 2 at 20:53
  • When using a regular LaTex document, for example the Overleaf example document, compiling it including a reference and a bibliography works well. I don't know how to compile the document using the kaobook class manually using overleaf. Could me link me an instruction for that? Unfortunately I didn't find one. I found out that overleaf uses the latexmk package to compile documents. Could it be a solution to try out a document specific configuration file? overleaf.com/learn/how-to/…
    – ljagg
    Commented Jan 2 at 21:29
  • Does the regular document also work with biblatex and biber, or does it use bibtex?
    – Marijn
    Commented Jan 2 at 21:32
  • I tried the example document here: en.wikibooks.org/wiki/LaTeX/… unfortunately I still get the same errors. I don't know how to manually compile a document using overleaf. The kaobook Template works perfectly well including references and bibliography when using overleaf.com (free AND paid version).
    – ljagg
    Commented Jan 2 at 21:47
  • Is Biber working correctly on your system, can you compile a document with it outside of Overleaf?
    – Marijn
    Commented Jan 3 at 9:13

1 Answer 1


After doing some further research I found this thread on the overleaf GitHub site: https://github.com/overleaf/overleaf/issues/1030 Following the instructions there solved the problem for me even though I didn't install another version of biber or python. In fact I updated the packages within the docker container using apt, updated every LaTex package using tlmgr, python packages within the CPAN shell and finally executed the tlmgr path add command. Now it works well. I don't know which of these steps solved the issue but as Bomme stated in the final post in the Thread i linked maybe it was the tlmgr path add command.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .