0

I don't have admin rights, getting the repository online is blocked and are not allowed to bypass it and I cannot put a USB drive on my computer. I do have MiKTeX installed (but basic so no package installed).

Because of all my limitations, the solution I found was to install LaTeX packages by simply using Copy/Paste on the packages. A colleague gave me the files and folders of LaTeX packages and I copied it to C:\Users\<my username>\AppData\Local\Programs\MiKTeX\. I then tested adding \usepackage{hyperref} in my .tex. I run pdflatex document.tex and get:

This is pdfTeX, Version 3.141592653-2.6-1.40.25 (MiKTeX 23.10) (preloaded format=pdflatex.fmt)
 restricted \write18 enabled.
entering extended mode
(document.tex
LaTeX2e <2023-06-01> patch level 1
L3 programming layer <2023-08-29>

(C:\Users\<User Name>\AppData\Local\Programs\MiKTeX\tex/latex/base\article.cls
Document Class: article 2023/05/17 v1.4n Standard LaTeX document class
(C:\Users\<User Name>\AppData\Local\Programs\MiKTeX\tex/latex/base\size10.clo))
(C:\Users\<User Name>\AppData\Local\Programs\MiKTeX\tex/generic/babel\babel.sty
(C:\Users\<User Name>\AppData\Local\Programs\MiKTeX\tex/generic/babel\txtbabel.def)
*************************************
* Local config file bblopts.cfg used
*

(C:\Users\<User Name>\AppData\Local\Programs\MiKTeX\tex/latex/arabi\bblopts.cfg)
(C:\Users\<User Name>\AppData\Local\Programs\MiKTeX\tex/latex/babel-english\english.ldf))
(C:\Users\<User Name>\AppData\Local\Programs\MiKTeX\tex/generic/babel/locale/en\babel-english.tex)
(C:\Users\<User Name>\AppData\Local\Programs\MiKTeX\tex/latex/hyperref\hyperref.sty

And opens the message:

enter image description here

I understand I succeded in installing hyperref but not ltxcmds. However, the file C:\Users\<User Name>\AppData\Local\Programs\MiKTeX\tex\generic\ltxcmds\ltxcmds.sty exists.

How can I tell MiKTeX to look there? In MiKTeX console I already have ``C:\Users<User Name>\AppData\Local\Programs\MiKTeX` in Settings -> Directories

Any other solution will be great.

3
  • Can you visit ctan? You can download zipped files from there, Unzip them in your directory and all will be fine.
    – yannisl
    Commented Jan 4 at 14:04
  • I could but I cannot download them all right? That is why a colleague that already downloaded a bunch of them was my fastest solution. I can go, however, to ltxcmds but the zip does not have any sty file inside. Now provided I downloaded it, where should I copy it's content? In tex/latex or tex/generic? Commented Jan 4 at 14:13
  • 1
    if the file is really already there try to update the file name database (in the miktex console in the menu tasks). (And check if you really have ltxcmds.sty, look for hidden extensions!) Commented Jan 4 at 14:13

1 Answer 1

0

Ok, the issue was that I should not put it in C:\Users\<User Name>\AppData\Local\Programs\MiKTeX\tex\generic\ltxcmds\ltxcmds.sty but in C:\Users\<User Name>\AppData\Local\Programs\MiKTeX\texmf\tex\generic\ltxcmds\ltxcmds.sty

I just doubled my tex folder in a new texmf folder. I have everything twice, very optimized, bit it works.

You can check where the package should go using the MiKTeX Console and going to Packages, select the package you want, then info and go to the Files tab.

2
  • 2
    that sounds definitively wrong, as according to your log hyperref is in \Programs\MiKTeX\tex/latex/. And on my machine the file is in AppData/Local/Programs/MiKTeX/tex/generic/ltxcmds/ltxcmds.sty. Commented Jan 4 at 15:28
  • Indeed, now I have problems with glossaries and it does not work... using neither of both paths... this installs seems quite broken Commented Jan 5 at 14:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .