0

I don't see any bibliography printed in the pdf after compiling. Can anyone please point out the problem? The following is my latex code

\documentclass{article}

% Page setup
\usepackage[a4paper, margin=2cm]{geometry}

% Math packages
\usepackage{amsmath}    % Enhanced math functionality
\usepackage{amssymb}    % Additional mathematical symbols
\usepackage{amsfonts}   % Mathematical fonts
\usepackage{mathtools}  % Enhancements to amsmath

% Commutative diagrams
\usepackage{tikz-cd}

% Bibliography
\usepackage[style=authoryear, backend=biber]{biblatex}
\addbibresource{references.bib}  % Specify the bibliography file

% Document starts here
\begin{document}
    
\title{Notes on Lie-Triple systems and Lie-Yamaguti algebras}
\date{}
\maketitle
\vspace{-0.5in}

\begin{abstract}
    This is the abstract.
\end{abstract}
    
\section{Introduction}

\section{Bibliography}
Citations can be managed using \texttt{biblatex}. Here is a sample citation \parencite{author2020}.

% Print the bibliography
\printbibliography

\end{document}

And this is my .bib file

@article{author2020,
  author    = {Author, A.},
  title     = {Title of the Article},
  journal   = {Journal Name},
  year      = {2020},
  volume    = {1},
  number    = {2},
  pages     = {123-145},
  doi       = {10.1234/journal.2020.12345},
}

Error Messages:

After clicking on the button "Build & View" I got the following error messages:

Process started: bibtex "notes_LYA".aux

This is BibTeX, Version 0.99d (TeX Live 2022/dev/Debian)
The top-level auxiliary file: notes_LYA.aux
I found no \citation commands---while reading file notes_LYA.aux
I found no \bibdata command---while reading file notes_LYA.aux
I found no \bibstyle command---while reading file notes_LYA.aux
(There were 3 error messages)
Process exited with error(s)


Process started: pdflatex -synctex=1 -interaction=nonstopmode "notes_LYA".tex

Process exited normally
3
  • 1
    Works perfectly for me. Did you remember to invoke a biber run after the initial latex run and then run latex again after the biber run?
    – murray
    Jan 6 at 16:54
  • @murray I have edited the post to add the error messages I am getting after compiling my document. Please see them.
    – Saikat
    Jan 6 at 18:56
  • @DaiBowen Thank you very much. Yes, it does.
    – Saikat
    Jan 6 at 19:55

1 Answer 1

1

Following these steps helped me resolve the issue:

In TeX Studio, you can configure the bibliography tool by following these steps:

Open TeX Studio.

  1. Go to the menu bar and select "Options" -> "Configure TeX Studio."

  2. In the left sidebar, select "Build."

  3. In the "Default Bibliography Tool" dropdown menu, select "Biber" instead of "BibTeX."

  4. Click "OK" to apply the changes.

After making these changes, you can compile your LaTeX document again. TeX Studio should now use Biber for bibliography processing with Biblatex.

Not the answer you're looking for? Browse other questions tagged .