0

I am using XeLaTex to compile the following LaTeX-code:

\documentclass[]{book}
\usepackage[UKenglish]{babel}  % main language
\usepackage{xeCJK}  % for Japanese fonts (requires XeLaTeX)
\setCJKmainfont{IPAMincho} 

\usepackage{svg}  % causes the warning

\begin{document}

\includesvg[width=7cm]{example-image}  % tried different svg-files

This is text in UKenglish. 
これは日本語のテキストです。

\end{document}

with example-image.svg and resulting in the following output:

result of compiled LaTeX-code

I also obtain the warning "Package transparent Warning: Loading aborted, because pdfTeX is not running in PDF mode."

How do I get rid of that warning?

What I tried so far:

  • Other compilers. They work with \usepackage{svg}. But, they do not support \usepackage{xeCJK}, which I would like to use in order to just write Japanese characters whenever I like to in the document without having to put it into special brackets or similar.
  • svg-image to another format. I have a lot of svg-images to include and do not want to change them into other formats - to have a really good quality pdf in the end. The texts in the images should also be the same font as the text in the document.
4
  • 3
    well the transparent package doesn't work with xelatex. If you don't need transparency use \usepackage[notransparent]{svg} , if you need transparency you can try at the begin of your document (before \documentclass) \DocumentMetadata{} . This will load the extended pdf management. Japanese should also work with lualatex. Jan 24 at 14:29
  • \usepackage[notransparent]{svg} does indeed work for my case. Thank you! \DocumentMetadata{} works as well for my case, but I have not tried for transparency. The xeCJKpackage does not work with LuaLaTeX.
    – edgar
    Jan 24 at 15:05
  • I know that xeCJK doesn't work, but depending on your use case they are other solutions (e.g. luatexja). Jan 24 at 15:07
  • luatexja works for me as well, thank you!
    – edgar
    Jan 24 at 15:39

1 Answer 1

0

Summarizing @Ulrike Fischer's answers

XeLaTex (2 options):

  1. Use \usepackage[notransparent]{svg} in above's markup if transparency is not needed.
  2. Write \DocumentMetadata{} at the beginning of the begin of the markup before \documentclass.

LuaLaTex:

  1. Use \usepackage{luatexja} instead of \usepackage{xeCJK} \setCJKmainfont{IPAMincho} in above's markup.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .