I am working on a XeLaTeX document. I am almost done with my document, but I need to input text from a foreign language. I am running Mac OS X. I go to Preferences > Language & Text and in there I enable Gurmukhi - QWERTY. This allows me to input Punjabi characters, which I am able to see in MS Word. I want to input the following unicode characters:

ਰੋਂਦਾ ਬੱਚਾ  ਿੲਕ

However, when I simply paste it into my TeXworks file, it simply does not show up when I compile a PDF file. I have indeed tried to google this, but came up with nothing other than adding some of these statements to my preamble. I am pretty desperate at this point.

My preamble already looks like this:

\documentclass[a4paper,12pt]{article} %options: [a4paper, leqno, 11pt]

% -----Page Style-------------

% -----Symbols----------------


2 Answers 2


You need to load a font which contains these characters. Load an appropriate font using \setmainfont and all should be well.

  • someone by jleedev was able to solve my problem, suggesting I do this: \newfontfamily\gu{Gurmukhi MT} \begin{document} {\gu ਰੋਂਦਾ ਬੱਚਾ ਿੲਕ} It worked perfectly. Commented Dec 14, 2010 at 10:06

If you don’t want to (or can’t) use the same font for both alphabets, I think you have to explicitly choose the font when you need it.

\newfontfamily\gu{Gurmukhi MT}
{\gu ਰੋਂਦਾ ਬੱਚਾ  ਿੲਕ}

(On Mac you can use “Gurmukhi MT”; FreeSans and FreeSerif also contain the glyphs.)

Also: The inputenc package warns that it should not be loaded as XeTeX already uses UTF8.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .