1

I have a special unicode character "𝌠" in LyX. When language is set to czech (as is the actual text) and encodung set to "standard for given language" and "standard" language package, it shows this error:

Errors: could not find LaTeX command for character '𝌠' (value 0x1d320)

The description says those characters are not in selected encoding (whatever is standard for czech (why not unicode?))

Now there are 4 unicodes to select (why!?) enter image description here Selecting different combinations:

encoding langPackage error appearance
unicode(utf8) standard/automatic/always babel babel:haven't specified langauge option + inputend:unicode char 𝌠(U+1D320) special character missing
unicode(utf8)/cjk(utf8) none inputend:unicode char 𝌠(U+1D320) special character missing
xetex(utf8) none/standard/automatic none shown all diacritics garbled
xetex(utf8) always babel babel:haven't specified langauge option all diacritics garbled
ucs-extension(utf8x) none/standard/automatic/always babel babel:haven't specified langauge option + ucs:unknown unicode character... diacritics ok, character as codepoint

Disregarding the options both the lyx file and the itermediate tex file are correctly utf-8 encoded. This seems to show that xetex cripples all encoding diregarding anything else. Babel's com complaints about missing language selection (despite language being selected) influences nothing as does the language package selection.

Now what can be set to have that character rendered correctly (same as in LyX UI)?

intermediate Tex file:

\makeatletter
\def\input@path{{C:/Users/Lukas/Documents/MEGAsync/Dokumenty/ves/}}
\makeatother
\documentclass[czech]{article}
\usepackage[T1]{fontenc}
\usepackage[utf8x]{inputenc}
\usepackage{babel}
\begin{document}
special character: ''𝌠''
\end{document}

Possibly interesting part of log:

*************************************
* Local config file bblopts.cfg used
*
("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\arabi\bblopts.cfg"
File: bblopts.cfg 2005/09/08 v0.1 add Arabic and Farsi to "declared" options of
 babel
)

! Package babel Error: You haven't specified a language option.

See the babel package documentation for explanation.
Type  H <return>  for immediate help.
 ...                                              
                                                  
l.343 ...ry to proceed from here, type x to quit.}
                                                  
You need to specify a language, either as a global option
or as an optional argument to the \usepackage command;
You shouldn't try to proceed from here, type x to quit.

)

LaTeX Warning: Unused global option(s):
    [czech].

...

File: uninames.dat 2013/05/13 UCS: Unicode character names, compressed
)

! Package ucs Error: Unknown Unicode character 119584 = U+1D320,
(ucs)                possibly declared in uni-467.def.
(ucs)                Type H to see if it is available with options.

See the ucs package documentation for explanation.
Type  H <return>  for immediate help.

...

                                                  
l.10 special character: ''𝌠
                              ''
Unicode character 119584 = U+1D320:
TETRAGRAM FOR DUTIES
Character is not defined in uni-*.def files.
Enter I!<RET> to define the glyph.

[1

3
  • 1
    don't use utf8x use utf8 (which is the default) in pdflatex you would have to declare the character and specify how to typeset it, on xelatex or lualkatex you would just have to select a suitable font Feb 8 at 23:16
  • @DavidCarlisle: any particular reason for not using utf8x? That was the only one to show that missing character at least somehow...
    – Lukas
    Feb 11 at 22:48
  • 1
    utf8x breaks the standard utf8 handling. by default in current releases it does nothing other than warn it should not be used. It only does something if you also load the ucs package but that breaks things. If you absolutely need it for compatibility then it's there but don't use it on new documents. Feb 11 at 22:54

1 Answer 1

1

I can't help with lyx, but it's easy enough to set the character with lualatex or xelatex. On this machine my web browser uses Segoe UI Symbol to show the character in your question, so I used the same here.

enter image description here

\documentclass{article}
\usepackage{fontspec}
\newfontfamily\segoeui{Segoe UI Symbol}
\begin{document}

special character: ``{\segoeui 𝌠}''
\end{document}
3
  • it shows another error: \newfontfamily \segoeui{Segoe UI Symbol} The control sequence at the end of the top line of your error message was never \def'ed. I would assume a missing package?
    – Lukas
    Feb 11 at 12:02
  • @Lukas the code posted in my answer runs without error assuming you are on Windows so have the font. As you have shown no example I have to guess but I assume that you have \newfontfamily undefined which will mean you have not loaded fontspec (which will require lualatex or xelatex) I assume you can tell lyx to do that, I do not have lyx so can not help with lyx setup) Feb 11 at 12:09
  • Thanks. This works. I ended up re-installing both Lyx and Miktex to latest version, in Lyx in document settings other (non-latex) fonts need to be allowed and \newfontfamily\segoeui{Segoe UI Symbol} must go to document header.
    – Lukas
    Feb 11 at 22:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .