7

I have this code:

\documentclass{beamer}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{lmodern}
\usepackage[caption=false]{subfig}

\graphicspath{{/folder/images/}}

\title{}
\author{}

\begin{document}


\begin{figure}
\centering

\subfloat[][]{\includegraphics[scale=0.5]{Graph1}}

\end{figure}

\end{document}

Under the graph it shows me a label , "a". How can I not show it? Also, how to restart numbering of labels because the subfloat numbers all the figures from the beginning of the document?

  • Just use \subfloat{\includegraphics[scale=0.5]{Graph1}} without the optional arguments. – Werner Sep 11 '12 at 17:26
  • @Werner:!!And i was deleting only one []..Thanks!Also,how to start over numbering the labels?Because it is numbering all the subfloats from the beginning of the document.And ,could you make this an answer? – George Sep 11 '12 at 17:32
6

subfig provides a number of different inputs to its \subfloat macro. It's usage results in different captioning styles. From the subfig documentation (Table 2 of section 2.2.1 The \subfloat Command, p 4):

enter image description here

So, the only way to have a \subfloat without a caption is to use it as \subfloat{<stuff>} and remove both possible optional arguments.

\subfloat numbering, by default, is renewed with every figure environment. However, you can control the counter number by means of setting the subfigure counter. For example, \setcounter{subfigure}{4} will make your \subfloats be numbered from (e).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.