1

I'm new here so sorry in advance if I make any mistake.

I have defined a \mybox command using tikzset. However, it is not working properly as some weird shadowing is showing around it.

enter image description here

I would like to have only the black outline, without the shadow. My code is as follows:

\documentclass[11pt]{beamer}
\usepackage[utf8]{inputenc}
\usepackage[export]{adjustbox}
\usepackage{xcolor}
\usepackage{virginialake}
\usepackage{graphics}
\usepackage{multirow,rotating}
\usepackage{color}
\usepackage{hyperref}
\usepackage{tikz-cd}
\usepackage{array}
\usepackage{siunitx}
\usepackage{mathtools,nccmath}%
\usepackage{pifont}
\usepackage{adjustbox}
\usepackage{tikz-cd}
\usepackage{extarrows}

\tikzset{
  mybox/.style={
    draw,
    %fill=blue!20,
    rounded corners=8pt, % Adjust the corner radius as needed
    inner sep=7pt,
  }
}



\begin{document}

\begin{block}{}
    \begin{center} % Center the box on the page
      \begin{tikzpicture}
        \node[mybox]{
          \parbox{0.9\textwidth}{
          \centering Goal: Obtain "well-behaved" Gentzen-style sequent calculi for modal logics.
          }
        };
      \end{tikzpicture}
    
    \end{center}
  \end{block}

\end{document}
2

1 Answer 1

1

The shadow is around the block environment you wrapped around the tikzpicture (although only specify themes do have such a shadow and you don't load any of them...).

As your block does not have a background colour and you don't want the shadow, I would suggest to not use a block.

Some other comments:

  • using a parbox within the node, seems unnecessarily complicate. Instead you use set a text width for the node.

  • please don't load the same package multiple times

  • I'm not sure if https://github.com/teg/atomic-flows-ii/blob/master/virginialake.sty is the same version as the package you are using, but for me it causes an option clash for the xcolor package

  • if your tex distribution is up-to-date, you don't need \usepackage[utf8]{inputenc}, that's the default since a couple of years

  • you don't need to load xcolor, graphics, color or hyperref in a beamer document, beamer loads them for you

  • the frame environment is missing

  • use ``text'' to get opening and closing quotation marks


\RequirePackage{virginialake}
\documentclass[11pt]{beamer}
%\usepackage[utf8]{inputenc}
\usepackage[export]{adjustbox}
%\usepackage{xcolor}
%\usepackage{virginialake}
%\usepackage{graphics}
\usepackage{multirow,rotating}
%\usepackage{color}
%\usepackage{hyperref}
\usepackage{tikz-cd}
\usepackage{array}
\usepackage{siunitx}
\usepackage{mathtools,nccmath}%
\usepackage{pifont}
%\usepackage{adjustbox}
%\usepackage{tikz-cd}
\usepackage{extarrows}

\tikzset{
  mybox/.style={
    draw,
    %fill=blue!20,
    rounded corners=8pt, % Adjust the corner radius as needed
    inner sep=7pt,
  }
}

\begin{document}

\begin{frame}
    \begin{center}% Center the box on the page
      \begin{tikzpicture}
        \node[mybox,text width=.9\textwidth,align=flush center]{
          Goal: Obtain ``well-behaved'' Gentzen-style sequent calculi for modal logics.
        };
      \end{tikzpicture}%
    \end{center}
\end{frame}

\end{document}

enter image description here

2
  • 1
    Hi! yes this is it. Pretty basic solution afterall. Thank you very much
    – davinci_07
    Commented Feb 29 at 11:34
  • @davinci_07 You're welcome! Commented Feb 29 at 11:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .