0

I am editing a bilingual critical edition with reledmac, reledpar and LuaLaTeX. On the left page is the Greek text with critical apparatus and on the right page is the German translation.

It all looks fine but on the first left page msdata appears twice, not on the following left pages.

What I have done so far: I thought that it had to do with the fact that I have directly after \msdata many commands including for the critical apparatus, so I moved \msdata to another place temporarily. However, this didn’t work.

I hope someone can help me.

Here is my new MWE

\documentclass[headheight=8mm, paper=170mm:240mm, BCOR=20mm, open=any]{scrbook}

\usepackage[polutonikogreek, ngerman]{babel}
\usepackage{letterspace} % für Sperrungen
\usepackage{lipsum}

%% begin reledmac
\usepackage[%
series={A, B, C, D, E}, % A: Bezeugung, B: Wiedergabe, C: Querbezüge; 
% D: Verwendeter Text, E: Apparat
noend,                  % keine Endnotenapparate
noeledsec,              % keine eledsections et al.
noledgroup              % keine ledgroups           
]{reledmac}

\Xarrangement[]{paragraph}           % Apparateinträge in Paragraph, nicht jeder in eigener Zeile
\setmsdatalabel{}                    % Standardlabel für Bezeugung "Ms." löschen
\lineation{page}                     % auf jeder Seite Zeilen neu zählen
\linenummargin{outer}                % Zeilenzahlen außen
\Xnumberonlyfirstinline[][true]      % Zeilennummern nur einmal
\Xnumberonlyfirstintwolines[][true]
\Xtwolines[]{\,f.}                   % bei zwei Zeilen zweite durch "f." ersetzen
\Xtwolinesbutnotmore[]               % aber bei mehr als zwei Zeilen Begin und Ende nennen
\Xsymlinenum[]{$\parallel$}          % Symbol zwischen Lesarten aus einer Zeile
\Xnotenumfont[]{\bfseries}           % Zeilennummern fett
\Xnonbreakableafternumber[]          % kein Zeilenumbruch nach Zeilennummer
\Xlemmaseparator[A, B, C, D]{:}      % Zeichen nach Lemma
\Xnonumber[B, C, D]                  % nur Zeilennummern in Apparat E
\Xafterrule[]{4pt}                   % Anzahl Points nach den Apparatlinien
\rightnoteupfalse                    % sidenote beginnt rechts von Markierung

%% A: Bezeugung
\Xtxtbeforenotes[A]{\textls{Bezeugung}:}
\Xafternumber[A]{0pt}
\Xinplaceoflemmaseparator[A]{0pt}

%% B: Wiedergabe
\Xtxtbeforenotes[B]{\textls{Wiedergabe}:}
\Xafternumber[B]{0pt}
\Xinplaceoflemmaseparator[B]{0pt}
\newcommand\wiga[3][]{%
    \edtext{#2}{%
        \if$#1$#2\else\lemma{#1}\fi
        \Bfootnote{#3}
    }
}

%% end reledmac

\usepackage{reledpar} % für seitenweise parallele Darstellung von Griechisch und Deutsch
\firstlinenumR{10000000} % vermeidet Zeilennummerierung der rechten Seite

\begin{document}

\begin{pages}

\begin{Leftside}
\lineation{page}
\beginnumbering
\autopar

\pstart%
\msdata{L\,E\,S\,Lat.}%
    \textbf{\large{Titel}}
\pend
        
\pstart
\noindent
\edtext{%
    \lipsum
}
{%
    \lemma{%
        \textbf{§§\,1--5}
    }
    \Bfootnote{Text zu 1--5}
}
\pend

\pstart
%\wiga[\textbf{§§\,6\,f.}]{%
    \lipsum
%} % Wiedergabe
%{Text}
\pend
        
\endnumbering
\stopmsdata
\end{Leftside}
    
\begin{Rightside}
% Deutsche Übersetzung
\selectlanguage{ngerman}
\lineation{page}
\beginnumbering
\autopar
        
\pstart
    \textbf{\large{Titel}}
\pend

\pstart
\ledsidenote{2:1--5}
    \lipsum
\pend

\pstart
\ledsidenote{2:6--9}
    \lipsum
\pend
        
\endnumbering
\end{Rightside}
    
\end{pages}
\Pages

\end{document}
6
  • 1
    Welcome to TeX.SX! Thanks for the question and the example, but please shorten and simplify it until it is minimal (the "M" in "MWE"). In particular, your preamble contains too many specifications. Please cut them down to the minimum that still exhibits your issue.
    – marquinho
    Commented Mar 19 at 14:47
  • off topic, but to get much better and more usable letterspacing, I recommend dumping the old package soul in favor of \usepackage{letterspace} and then use the command \textls{} (or just load \usepackage{microtype} which contains letterspace).
    – marquinho
    Commented Mar 19 at 14:51
  • 1
    thanks for the hint with letterspace
    – Cor
    Commented Mar 19 at 16:18
  • Thanks for editing and sorry to bother you again. In order to compile your new example, I need to remove the custom commands \vari, \quer, \wiga and \parcnt, because they are not defined in your snippet. (In other words: the MWE isn't really "Working".) But if I go through with this, the issue disappears: there is only one instance of msdata ("LES Lat."). ...
    – marquinho
    Commented Mar 19 at 16:31
  • 1
    I have found the culprit/s. It seems to be a combination of \msdata and my command \wiga = \edtext{text}\Bfootnote{footnote}. It does not matter if I use my short command or the full command. If I comment them out, \msdata only appears once. If one of two of them is active, \msdata appears twice on the first left page. Maybe it has to do with my general settings of reledmac/reledpar. I will add a new MWE.
    – Cor
    Commented Mar 21 at 15:04

1 Answer 1

0

This will sound unhelpful, but... As far as your example is concerned, the problem boils down to your use of \lipsum in conjunction with critical footnotes, specifically inside \edtext. (And your custom command \wiga isn't directly responsible for it.)

Assuming that your real document contains actual text instead of \lipsum, this answer might be unsatisfactory, formalistic and useless. But there's a chance that it might point you in the right direction – maybe there's something happening inside your actual document's \edtext that shouldn't - so I'm posting it anyway.

I've distilled your code down to a truly minimal example.

\documentclass{article}

\usepackage{lipsum}
\usepackage{reledmac}
\usepackage{reledpar}

%%%             This custom definition has some issues, see below
\newcommand\wiga[3][]{%
    \edtext{#2}{%
        \if$#1$#2\else\lemma{#1}\fi
        \Bfootnote{#3}
    }
}

\begin{document}

\begin{pages}
\begin{Leftside}
\lineation{page}
\beginnumbering
\autopar

\pstart
\msdata{This text must appear only once!}%
Title
\pend
        
\pstart
\wiga[My lemma]{%
Some
%\lipsum            % try uncommenting this
text%
}{My footnote}
\lipsum         % try commenting this out
%
\edtext{Some 
%\lipsum            % try uncommenting this
text%
}{\lemma{My lemma}\Bfootnote{My footnote}}
\pend
        
\endnumbering
\stopmsdata
\end{Leftside}
    
\begin{Rightside}
\lineation{page}
\beginnumbering
\autopar
        
\pstart
Title
\pend

\pstart
\lipsum
\pend
        
\endnumbering
\end{Rightside}
\end{pages}
\Pages

\end{document}

Note that I have kept the calls of \lipsum strictly outside of the argument \edtext of the single footnote, and of the arguments of \wiga, which is but an alias for \edtext...\Bfootnote. In this case, there is no issue with the repetition of the text in \msdata.

enter image description here

However, if you use \lipsum inside \edtext or the first mandatory argument of \wiga (which is the same thing!), the \msdata text is printed twice.

enter image description here

I do not know what it is that \lipsum does and the \edtext cannot digest – though if I had to guess, I'd say it inserts implicit paragraph breaks (one call of \lipsum prints seven paragraphs of "Lorem ipsum"). We know that \edtext is a "short" macro, i.e. it forbids paragraph breaks in its argument (and even throws an error if you leave an empty line). On the other hand, it appears that any breaks created by \lipsum can just slide past \edtext – only they'll come back to bite you in the form of inconsistencies and repetitions.

Maybe you'll find something similar in your document that is the source of the repetition.

To isolate the culprit, reduction (minimality) is the way to go: strip down your code like I did with the MWE above, until you have a simple configuration that still produces the issue.

Improvements to custom command \wiga

  1. Pay attention to the line breaks: By leaving too many line breaks unprotected, you'll get some spurious spaces in the document (in the main text as well as the apparatus). This is true of \wiga and of all reledmac footnotes at large:
\newcommand\wiga[3][]{%
    \edtext{#2}{%
        \if$#1$#2\else\lemma{#1}\fi
        \Bfootnote{#3}
    }     % this should be: }%
}

\edtext{%
    Some        % this should be: Some%
}
{%
    \lemma{%
        \textbf{§§\,1--5}       % this should be: }%
    }
    \Bfootnote{Text zu 1--5}    % this should be: }%
}
Text

% or even better: 
\edtext{Some}{%
    \lemma{\textbf{§§\,1--5}}%
    \Bfootnote{Text zu 1--5}}
Text
  1. I'm not sure how the conditional \if$#1$#2\else\lemma{#1}\fi is meant to work (why the math mode?), but in practice, it doesn't. When #1 is empty, the command prints #2 twice.
    You seem to want a command that prints \edtext{#2}{\lemma{#1}\Bfootnote{#3}, where #1 is optional and, if undefined, defaults to #2.
    The canonical (and effective) way to do this, with any recent TeX distribution (>2020), is the following:
\NewDocumentCommand{\wiga}{O{#2} m m}%
{\edtext{#2}{\lemma{#1}\Bfootnote{#3}}}
2
  • Thanks a lot for your suggestions and your answer! I tested your suggestions, and the problem seems to have to do with implicit paragraph breaks in \lipsum and spurious spaces. Probably, there is an implicit paragraph in my document as well (which I did not find so far).
    – Cor
    Commented Mar 26 at 11:25
  • @Cor Yes, I think it's worth looking for such a paragraph break. Maybe you are using \` or \newline` inside a \pstart? Some TeX mechanisms might react funny to that. Or maybe you have a custom command that introduces a paragraph or line break? (Just guessing, but that's where I would start looking in my own document)
    – marquinho
    Commented Mar 26 at 12:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .