0

When attempting to compile the following input under either pdflatex (MiKTeX-pdfTeX 4.19 (MiKTeX 24.3.31)) or lualatex (LuaHBTeX, Version 1.18.1 (MiKTeX 24.3.31)), I got errors thrown by something to do with the hyperref package.

\documentclass[12pt]{book}

\usepackage{hyperref}

\begin{document}
    \frontmatter
    \tableofcontents
    \mainmatter
    \chapter{Lorem Ipsum}
    Lorem ipsum dolor sit amet    
\end{document}

According to the miktex package manager, I have version 7.01h of hyperref installed. The error is as shown:

("C:/Users/[Username]/AppData/Local/Programs/MiKTeX/tex/latex/base/atbegshi-
ltx.sty"
Package: atbegshi-ltx 2021/01/10 v1.0c Emulation of the original atbegshi
package with kernel methods
)
\Hy@abspage=\count268
\c@Item=\count269
\c@Hfootnote=\count270
)
! Extra \else.
\Hy@AtEndOfPackageHook ...color}\fi \fi \fi \else 
                                                  \def \HyOpt@DriverType { (...
l.4 

I have also included the log_file file, and a list of the packages installed on my system. Please let me know if there is anything that I should do to remediate this issue.

5
  • You didn't update everything. Probably the iftex package is outdated. Check for updates in user and admin mode! Apr 15 at 6:16
  • @UlrikeFischer I checked the version of iftex, and it's 1.0f, which is the most recent according to CTAN. I also checked for updates as an admin and as a user, and the console says everything is up to date.
    – Edgetho
    Apr 15 at 14:12
  • your log says that you are using 1.0d: 2020/03/06 v1.0d Apr 15 at 14:19
  • @UlrikeFischer thanks for your help. When I run miktex packages info iftex I get v1.0f. I tried refreshing the file name data base with miktex fndb refresh in case that was the issue, and calling miktex package check-update (there were no updates) as admin and as user, but it still calls 1.0d when I acutally call lualatex. Is there a way to rebuild what miktex thinks is installed on my system?
    – Edgetho
    Apr 15 at 14:51
  • @UlrikeFischer I tried running miktex packages remove iftex then miktex packages install iftex, and that reinstall worked. Not sure how the versions got mismatched, and thank you for your help!
    – Edgetho
    Apr 15 at 14:56

0

You must log in to answer this question.

Browse other questions tagged .