1

I am trying to set up my config file, so that biblatex will not print pagetotal even for books. I would prefer to keep the information in my bib-file, so instead of removing pagetotal info there, I was wondering if it is possible to suppress its printing.

I have tried to use "pagetotal=false" as found here: docu

But I receive an error, saying the command is unknown: Package xkeyval Error: pagetotal undefined in families blx@opt@pre.

MWE


%----------------------------------------------------------------------------
%   LAYOUT
%----------------------------------------------------------------------------
\documentclass[
  12pt,
  a4paper,
  %parskip,
  headings=standardclasses,
  listof=totoc,
  numbers=noenddot
]{scrartcl}

\usepackage[hmargin=2.5cm, top=2.5cm, bottom=2cm, footskip=1cm]{geometry}
\usepackage[onehalfspacing]{setspace}
\usepackage[main=ngerman, english]{babel}
\usepackage[babel, german=quotes]{csquotes}
\usepackage[ngerman]{isodate}
\usepackage[ngerman]{datetime}
\usepackage{hyphenat}% create hypen without overfull box

%----------------------------------------------------------------------------
%   TOC
%----------------------------------------------------------------------------
\KOMAoptions{toc=sectionentrydotfill}
\KOMAoption{captions}{tableheading}% correct TOC count for tables
\renewcaptionname{ngerman}{\contentsname}{TOC}
\BeforeTOCHead[toc]{{\pdfbookmark[1]{\contentsname}{toc}}}% TOC in bookmarks
\AddtoDoHook{heading/preinit/part}{\clearpage\vspace*{\stretch{1}}}
\AddtoDoHook{heading/endgroup/part}{\vspace*{\stretch{2}}\clearpage}
\setkomafont{partprefix}{\usekomafont{part}}
%----------------------------------------------------------------------------
%   BIB
%----------------------------------------------------------------------------
\usepackage[
  backend=biber,
  style=ext-authoryear,
  sorting=nyvt,
  datamodel=customstyles,
  maxnames=25,
  innamebeforetitle=true,
  usetranslator=true,
  alldates=terse,
  labeldate=year,
  dashed=false,
  doi=false,
  isbn=false,
  url=false,
  pagetotal=false
]{biblatex}
\AtEveryBibitem{\clearlist{language}}
\addbibresource{library.bib}
\usepackage[hidelinks, pdfencoding=auto]{hyperref}
\usepackage{microtype}% avoid bib formatting issues



%----------------------------------------------------------------------------
%   MAIN
%----------------------------------------------------------------------------

\begin{document}

\nocite{*} 
\clearpage
\printbibliography

\end{document}

My library.bib file:

@book{Lakoff.1987-WomenFireDangerous,
  title = {Women, Fire, and Dangerous Things. What Categories Reveal about the Mind},
  author = {Lakoff, George},
  date = {1987},
  publisher = {The University of Chicago Press},
  location = {Chicago},
  isbn = {978-0-226-46804-4},
  pagetotal = {614},
}

1 Answer 1

1

The linked documentation is for the styles of the biblatex-iso690 bundle. The biblatex-ext and standard styles do not support a pagetotal option.

You can delete fields with the \AtEveryBibitem-\clearfield/\clearlist/\clearname trick that you are already using for language

\AtEveryBibitem{%
  \clearlist{language}%
  \clearfield{pagetotal}%
}

Or you can use a sourcemap to get rid of the data while it is read from the .bib file. This is usually my preferred option because then the field contents are effectively not seen by biblatex and Biber at all, which means that they also will not factor into "less visible things" like sorting. (The other advantage of a sourcemap is that you don't have to worry about the "type" of the field [field/list/name], you can use the same idiom for all types.)

MWE with sourcemap

\documentclass[12pt, a4paper,]{scrartcl}

\usepackage[main=ngerman, english]{babel}
\usepackage[babel, german=quotes]{csquotes}
\usepackage[
  backend=biber,
  style=ext-authoryear,
  sorting=nyvt,
  maxnames=25,
  innamebeforetitle=true,
  usetranslator=true,
  alldates=terse,
  labeldate=year,
  dashed=false,
  doi=false,
  isbn=false,
  url=false,
]{biblatex}

\DeclareSourcemap{
  \maps[datatype=bibtex, overwrite]{
    \map{
      \step[fieldset=language, null]
      \step[fieldset=pagetotal, null]
    }
  }
}

\usepackage[hidelinks, pdfencoding=auto]{hyperref}
\usepackage{microtype}

\begin{filecontents}{\jobname.bib}
@book{Lakoff.1987-WomenFireDangerous,
  title     = {Women, Fire, and Dangerous Things. What Categories Reveal about the Mind},
  author    = {Lakoff, George},
  date      = {1987},
  publisher = {The University of Chicago Press},
  location  = {Chicago},
  isbn      = {978-0-226-46804-4},
  pagetotal = {614},
}
\end{filecontents}
\addbibresource{\jobname.bib}

\begin{document}
\nocite{*} 
\printbibliography
\end{document}

Lakoff, George (1987). Women, Fire, and Dangerous Things. What Categories Reveal about the Mind. Chicago: The University of Chicago Press.

3

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .