1

Here are two failed attempts to install the downloaded (by MiKTeX) files for babel-scottish. It seems to revolve around the missing file hilatex-dev.fmt presumably needed for XeLaTeX. The internet seems strangely quiet if you attempt a search for this file, so I am at a loss to solve the update formats problem. There doesn't seem to be the necessary update button in the MikTeX Console to rebuild the language database. What should I try next?

C:\Users\hsmye>miktex --enable-installer formats build
security risk: running with elevated privileges
Building format 'latex-dev' with engine 'pdftex'...
Building format 'amstex' with engine 'pdftex'...
Building format 'lualatex-dev' with engine 'luahbtex'...
Building format 'pdfcslatex' with engine 'pdftex'...
Building format 'pdfcsplain' with engine 'pdftex'...
Building format 'dviluatex' with engine 'luatex'...
Building format 'csplain' with engine 'pdftex'...
Building format 'cslatex' with engine 'pdftex'...
Building format 'mltex' with engine 'pdftex'...
Building format 'bagpipe' with engine 'pdftex'...
Building format 'lualatex' with engine 'luahbtex'...
Building format 'bplain' with engine 'pdftex'...
Building format 'optex' with engine 'luatex'...
Building format 'bagpipex' with engine 'pdftex'...
Building format 'dvilualatex-dev' with engine 'luatex'...
Building format 'dvilualatex' with engine 'luatex'...
Building format 'etex' with engine 'pdftex'...
Building format 'lollipop' with engine 'pdftex'...
Building format 'hilatex' with engine 'hitex'...
Building format 'hilatex-dev' with engine 'hitex'...

Sorry, but: Windows API error 2: The system cannot find the file specified.

C:\Users\hsmye>

initexmf --dump
2024-04-25 11:43:37,451-0600 INFO  initexmf - Operating on the private (per-user) MiKTeX setup
2024-04-25 11:43:37,456-0600 INFO  initexmf - running: miktex --enable-installer formats build
2024-04-25 11:43:37,456-0600 INFO  initexmf.core - start process: miktex --enable-installer formats build
2024-04-25 11:45:32,696-0600 INFO  initexmf - this is MiKTeX Configuration Utility 5.5 (MiKTeX 24.3.31)
2024-04-25 11:45:32,696-0600 INFO  initexmf - this process (21316) started by cmd in directory C:\Users\hsmye with command line: initexmf --help
2024-04-25 11:45:32,696-0600 INFO  initexmf - Operating on the private (per-user) MiKTeX setup
2024-04-25 11:46:28,488-0600 ERROR initexmf - sub-process error output has been saved to 'C:\Users\hsmye\AppData\Local\MiKTeX\miktex\log\miktex_2024-04-25-114628.out'
2024-04-25 11:46:28,488-0600 FATAL initexmf - Windows API error 2: The system cannot find the file specified.
2024-04-25 11:46:28,489-0600 FATAL initexmf - Info: existing="C:\Users\hsmye\AppData\Local\Temp\mik45435\hilatex-dev.fmt", path="C:\Users\hsmye\AppData\Local\MiKTeX\miktex/data/le/hitex\hilatex-dev.fmt"
2024-04-25 11:46:28,489-0600 FATAL initexmf - Source: Libraries\MiKTeX\Core\File\win\winFile.cpp
2024-04-25 11:46:28,489-0600 FATAL initexmf - Line: 376
2024-04-25 11:46:28,490-0600 INFO  initexmf - this process (16556) finishes with exit code 1

Sorry about the length; this is as close to an MWE as I can get.

BTW, have you ever seen a Windows install that buchered a user name? Notice the user name in the log files…

Almost forgot, here is the warning in a run with XeLaTeX

[{
    "resource": "/C:/Users/hsmye/AppData/Local/Programs/MiKTeX/tex/latex/babel-scottish/scottishgaelic.ldf",
    "owner": "LaTeX",
    "severity": 4,
    "message": "Package babel: No hyphenation patterns were preloaded for\n(babel)\tthe language 'Scottish Gaelic' into the format.\n(babel)\tPlease, configure your TeX system to add them and\n(babel)\trebuild the format. Now I will use the patterns\n(babel)\tpreloaded for \\language=0 instead.",
    "source": "LaTeX",
    "startLineNumber": 41,
    "startColumn": 1,
    "endLineNumber": 41,
    "endColumn": 65536
}]

Sorry about the formatting of the message, but this is what a 'copy' returns.

New information, this is from my current run

(C:\Users\hsmye\AppData\Local\Programs\MiKTeX\tex/latex/babel-scottish\scottish.ldf (C:\Users\hsmye\AppData\Local\Programs\MiKTeX\tex/latex/babel-scottish\scottishgaelic.ldf

Package babel Warning: No hyphenation patterns were preloaded for
(babel)                the language 'Scottish Gaelic' into the format.
(babel)                Please, configure your TeX system to add them and
(babel)                rebuild the format. Now I will use the patterns
(babel)                preloaded for \language=0 instead on input line 41.

It clearly knows about the necessary files but can't seem to get to them. I've filed a bug report in GitHub with MikTeX.

17
  • 2
    hilatex(-dev) is unrelated to xetex it is for the new hitex engine Apr 26 at 17:38
  • Thanks for the update, that makes this the first point of error, then @DavidCarlisle
    – hsmyers
    Apr 26 at 17:54
  • it looks like an error in the setup for format building but I don't know how that's configured in miktex so someone else will have to answer Apr 26 at 17:58
  • the format building fails for me too but don't see a reason. The hilatex format works. You should report that. In the mean time you can exclude the format in the miktex console in the settings. Apr 26 at 18:07
  • 1
    My experience so far is that no hyphenation is taken unless I tell it where with \- I'd like to say that as this is a beginner's text, there are no long words, but this is Scottish Gaelic, and there is no such thing as only short words! You are right, @cfr, warnings are necessary, but it is irritating when you can't fix the problem you've been warned about!
    – hsmyers
    Apr 28 at 15:16

0

You must log in to answer this question.

Browse other questions tagged .