0

All of a sudden (for me), the usual font setup I use does not work anymore.

Not only does the line with inter produce the error

(/usr/share/texmf-dist/tex/latex/inter/inter.sty Package: inter 2023/11/23 (Carl-Clemens Ebinger & autoinst) Style file for inter fonts (Inter v.4.0)

(/usr/share/texmf-dist/tex/latex/base/fontenc.sty Package: fontenc 2021/04/29 v2.0v Standard LaTeX package

! Package fontenc Error: Encoding file `lgrenc.def' not found. (fontenc) You might have misspelt the name of the encoding.

but also prohibits serif font / roman font family from being typeset.

Is there a solution to this for the time being until it gets patched or is the setup now wrong (for whatever reason)?

Screenshot of MWE (problem)

enter image description here

Screenshot of MWE (with the line containing inter commented out)

enter image description here

MWE

\documentclass[
a4paper,
DIV=15,
fontsize=10pt,
]
{scrreport}

\usepackage[english]{babel}
\usepackage[
oldstyle,
]{sourceserifpro}
\usepackage[scale=1.02]{zi4}
\usepackage[scale=0.935]{inter}


\usepackage[
protrusion=true,
expansion,
babel=true,
%stretch=10,
%shrink=10,
tracking=true,
]{microtype}

\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}

\begin{document}
\sffamily
\begin{itemize}
    \item wordstuff 
    \begin{itemize}
        \item \rmfamily A sentence to showcase the problem.
        \item \textrm{asdf}
    \end{itemize}
\end{itemize}
\end{document}
12
  • 1
    works fine for me. Show your complete log-file (that means I get no error). Commented Apr 27 at 22:29
  • 2
    The error about lgrenc.def not being found means you have a bad installation of the TeX system. What TeX distribution are you using?
    – egreg
    Commented Apr 27 at 22:35
  • 1
    lgrenc.def is part of the the texlive greek-fontenc package but how it should be installed depends on the tex distribution you are using. Commented Apr 27 at 23:18
  • 1
    If you're on Linux, tell us which distro and which packages you installed to install TeX.
    – cfr
    Commented Apr 28 at 1:14
  • 1
    it's possible that the inter package (which uses non standard font shape names) is confused by some changes elsewhere and it wasn't intended to change the whole document to sans serif. (it does have options default and sfdefault and mainfont, but they didn't seem to do much and I didn't trace the code) Commented Apr 28 at 10:32

1 Answer 1

1

You are using largely undocumented font packages after installing a very minimal tex installation.

The inter package makes everything sans serif, the simplest thing here is probably just load it first then load the source serif pro package later to reset the \rmfamily

enter image description here

\documentclass[
a4paper,
DIV=15,
fontsize=10pt,
]
{scrreport}


\usepackage[english]{babel}
\usepackage[sfdefault,scale=0.935]{inter}
\usepackage[
oldstyle,
]{sourceserifpro}
\usepackage[scale=1.02]{zi4}



\usepackage[
protrusion=true,
expansion,
babel=true,
%stretch=10,
%shrink=10,
tracking=true,
]{microtype}

\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}

\begin{document}
\sffamily
\begin{itemize}
    \item wordstuff 
    \begin{itemize}
        \item \rmfamily A sentence to showcase the problem.
        \item \textrm{asdf}
    \end{itemize}
\end{itemize}
\end{document}

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .