1

It is needed to compile standalone and musixflx for a musixtex. The basic code is as follow:

\documentclass[
border={0.3cm % Izquierda
    2pt % Abajo
    15.1cm % Derecha
    +3pt % Arriba
},landscape,a1paper,10pt,class=scrartcl]{standalone}
%},landscape]{article}
\usepackage{musicography}
\usepackage{musixtex}
\input musixlyr
\usepackage{amsmath}
\usepackage{xcolor}
\xdefinecolor{red-undar}{RGB}{179,35,79}
\begin{document}
\begin{music}
\font\A=phvb8t at 8pt% added for letter type.
\font\B=phvb8t at 9pt% added for letter type.
\instrumentnumber{1}
\nobarnumbers
\setclef1\treble
\generalmeter{\meterfrac34}
\parindent0mm
\nostartrule
\def\writebarno{\A\the\barno}
%\renewcommand*\writebarno{\textit{\the\barno}}%
%\scale{1.0}%
\startbarno=1%
\startpiece% 
\notes\loffset{2.8}{\zchar{12}{\metron{\qu}{\B80}\lyricsoff}}\ql{iii}\en\bar%
\notes\hl l\ql l\en\bar%
\notes\ql{nki}\en\bar%
\notes\hl k\ql k\en\bar%
\notes\ql{klk}\en\bar%
\notes\hl i\ql i\en\bar%
\notes\ql{hig}\en\bar%
\notes\hup{e}\sk\en%
\notes\ql{ggh}\en%\bar
\alaligne%
\notes\hl i\ql i\en\bar%
\notes\ql{klk}\en\bar%
\notes\hl i\ql i\en\bar%
\notes\ql{klk}\en\bar%
\notes\hl i\ql i\en\bar%
\notes\ql{hih}\en\bar%
\notes\hup{e}\sk\en%    
\setdoubleBAR%
\nolyr%
\lyricsoff%
\endpiece
\end{music}
\end{document}

The current output is as follow: current

5
  • 4
    Could you clarify what 'not working' means? [I don't know why this got down voted without any explanation.] But having typearea and standalone fighting over the page layout probably isn't good. I don't get the output you show from the code you provide.
    – cfr
    Commented Jun 10 at 19:05
  • Hi Cfr. what environment are you using? wich tool you use to compile?
    – ABV
    Commented Jun 10 at 21:53
  • Can you add a quick drawing of the expected output?
    – Mane32
    Commented Jun 10 at 21:56
  • Probably pdfTeX. Might have been luaTeX. Why? Is the output engine-dependent?
    – cfr
    Commented Jun 10 at 23:31
  • 1
    Your title is confusing: \musixflx does work. It is \alaligne which does not produce the desired effect: it starts a new line, but puts it next to the previous instead of beneath. Besides: I think you broke the line one measure too late.
    – C. Peters
    Commented Jun 11 at 7:07

1 Answer 1

7

To be able to have staves vertically (as in a standard documentclass), the [varwidth] option of standalone is required.

Also, Since you don't need to use a1paper or a koma script class (to avoid typearea incompatibilities), I used the standard article documentclass as the base class of standalone (it is default config anyway).

\documentclass[border=10pt,varwidth]{standalone}
\usepackage{musicography}
\usepackage{musixtex}
\input musixlyr
\begin{document}
\begin{music}
    \font\A=phvb8t at 8pt% added for letter type.
    \font\B=phvb8t at 9pt% added for letter type.
    \instrumentnumber{1}
    \nobarnumbers
    \setclef1\treble
    \generalmeter{\meterfrac34}
    \parindent0mm
    \nostartrule
    \def\writebarno{\A\the\barno}
    \startbarno=1%
    \startpiece%
    \notes\loffset{2.8}{\zchar{12}{\metron{\qu}{\B80}}}\ql{iii}\en\bar%
    \notes\hl l\ql l\en\bar%
    \notes\ql{nki}\en\bar%
    \notes\hl k\ql k\en\bar%
    \notes\ql{klk}\en\bar%
    \notes\hl i\ql i\en\bar%
    \notes\ql{hig}\en\bar%
    \notes\hup{e}\sk\en%
    \notes\ql{ggh}\en%\bar
    \alaligne%
    \notes\hl{i}\ql i\en\bar%
    \notes\ql{klk}\en\bar%
    \notes\hl i\ql i\en\bar%
    \notes\ql{klk}\en\bar%
    \notes\hl i\ql i\en\bar%
    \notes\ql{hih}\en\bar%
    \notes\hup{e}\sk\en%
    \setdoubleBAR%
    \endpiece
\end{music}
\end{document}

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .