1

If you install Miktex 24.1 (Windows) and call up "Check for updates" and "Update now" via the console, the update runs until approx. 42% then the process starts to corrupt the entire installation. After termination of the frozen console (after hours), none of the Miktex programs work any more.

If you then call up the console, several error messages of the type


miktex-console.exe - System error

The execution of the code cannot be continued because MiKTeX240400-log4cxx.dll was not found. The problem can possibly be solved by reinstalling the program.

OK

(with various DLLs that are not found) occur.

The problem occurs under both Windows 10 and Windows 11 (latest patch level). And it seems to affect all versions of Miktex since 2.9.

If you search the internet for the problem, you will see that I am not the only one experiencing it.

I reported the problem with V23 as an issue on GitHub last year, but Mr. Schnek only replied that he couldn't solve the problem and blocked me.

Maybe someone knows - if it is due to specific Windows quirks - what I have to do to prevent it from occurring?

Regards MM

4
  • sorry but how should anyone be able to help you? Obviously it is a rare, local problem as there aren't any open issues about that. Check if you have some overeager virus protection that blocks the installation. And if you can not resolve the problem install TeXlive. Commented Jun 19 at 16:41
  • no, its not rare, it occur on several computers with win 10 and 11, some with viruscanner some without. And the installation went ok and all is functioning until you try the integrated update... so I think its worth a question.. but ok.. i'l give texlive a try
    – mmm88
    Commented Jun 20 at 20:35
  • I have run into the same problem. In fact, updates breaking my installation has happened multiple times within the last three to four months.
    – Dan
    Commented Jun 21 at 12:54
  • please set an Issue at github, may be, the if more people report that, the earlier it will earn the attention it deserves and than it get fixed.
    – mmm88
    Commented Jun 21 at 13:51

1 Answer 1

1

I had the same problem across three win 10 machines. A complete re-installation of MiKTeX solved the problem. It did require manual removal of the old files, as the installation program complained that the installation directory was not empty. MiKTeX was no longer on the list of apps even if I had not removed anything, so I was unable to uninstall properly.

I have not dared to update MiKTeX, though...

1
  • It's not an answer ...
    – jotagah
    Commented Jun 24 at 11:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .