4

I compiled this MWE

\RequirePackage[2024-05-01]{latexrelease}

\documentclass{article}

\usepackage{pdfx}

\begin{document}

This is NOT an item.

\begin{itemize}
\item This is an item.
\end{itemize}

\end{document}

with

lualatex -interaction=nonstopmode ./foo.tex
echo $? # in Bash this command prints exit code of lualatex, it is 1

I had to add the first line to solve a pdfx issue as suggested here.

Unfortunately, lualatex complains:

! LaTeX Error: Something's wrong--perhaps a missing \item.

If I comment out itemize environment, everything will work. The same error message also appears if you comment out \item.

3
  • 4
    Try a version/date before 2023-06-01 instead of 2024-05-01.
    – cabohah
    Commented Jun 20 at 10:38
  • 1
    note that getting the item error on rollback happens even without pdfx and is a bug: github.com/latex3/latex2e/issues/1386 Commented Jun 20 at 19:10
  • 2
    Note, that you don't need the workaround any longer. The new version of pdfx does not load package xmpincl inside a group. So you can remove \RequirePackage[2024-05-01]{latexrelease}. Also the new version of latexrelease can correctly rollback without error. So an update would fix both issues.
    – cabohah
    Commented Jul 2 at 9:25

1 Answer 1

4

I would not roll back latex, especially if you are interested in tagging.

Packages should never have been loaded in a group but you can silence the check just while loading pdfx by hiding the group level

%\RequirePackage[2024-05-01]{latexrelease}

\documentclass{article}

\let\foo\currentgrouplevel
\chardef\currentgrouplevel0
\usepackage{pdfx}
\let\currentgrouplevel\foo

\begin{document}

This is NOT an item.

\begin{itemize}
\item This is an item.
\end{itemize}

\end{document}

The package in principle should not work correctly when loaded this way but if it worked well enough before the check was added, this should make it do the same.

Not the answer you're looking for? Browse other questions tagged .