I've tried to compile a document with XeLaTeX (TeXLive 2012) and both mathspec and microtype (version 2.5 which supports XeLaTeX). I need a 10.5pt font in the document, so I redefine the \normalsize command. It all works fine, but when I try to use microtype package it fails and I got the following error message

LaTeX Font Warning: Font shape `OML/cmm/m/it' in size <10.5> not available
(Font)              size <10.95> substituted on input line 14.

! Cannot use \XeTeXcharglyph with cmmi5; not a native platform font.
\MT@get@slot@ ...rest \@tempcnta =\XeTeXcharglyph 
                                              \MT@char \relax \ifnum \@t...
l.14 \[

With fontspec it works, with mathspec it doesn't. Does anybody have an idea what's going on here?

This is my document


\setmainfont[Numbers=Lining, Ligatures=TeX]{Minion Pro}
\setmathfont(Digits,Greek,Latin)[Numbers=Lining]{Minion Pro}


\sum_{i=1}^\infty \alpha^i


The part of the log with \listfiles looks like this

*File List*
article.cls    2007/10/19 v1.4h Standard LaTeX document class 
size10.clo      2007/10/19 v1.4h Standard LaTeX file (size option)
mathspec.sty    2009/09/30 v0.2 LaTeX Package (Mathematics font selection 
for XeLaTeX)
etoolbox.sty    2011/01/03 v2.1 e-TeX tools for LaTeX
etex.sty    1998/03/26 v2.0 eTeX basic definition package (PEB)
amstext.sty    2000/06/29 v2.01
amsgen.sty    1999/11/30 v2.0
ifxetex.sty    2010/09/12 v0.6 Provides ifxetex conditional
fontspec.sty    2012/05/06 v2.2b Advanced font selection for     
expl3.sty    2012/07/16 v3990 L3 Experimental code bundle wrapper
l3names.sty    2012/07/16 v3990 L3 Namespace for primitives
l3bootstrap.sty    2012/07/15 v3986 L3 Experimental bootstrap code
l3basics.sty    2012/07/15 v3987 L3 Basic definitions
l3expan.sty    2012/07/15 v3986 L3 Argument expansion
l3tl.sty    2012/07/15 v3986 L3 Token lists
l3seq.sty    2012/07/15 v3986 L3 Sequences and stacks
l3int.sty    2012/07/15 v3986 L3 Integers
l3quark.sty    2012/07/15 v3986 L3 Quarks
l3prg.sty    2012/07/15 v3986 L3 Control structures
l3clist.sty    2012/07/15 v3986 L3 Comma separated lists
l3token.sty    2012/07/15 v3986 L3 Experimental token manipulation
l3prop.sty    2012/07/15 v3986 L3 Property lists
l3msg.sty    2012/07/15 v3986 L3 Messages
l3file.sty    2012/07/15 v3986 L3 File and I/O operations
l3skip.sty    2012/07/15 v3986 L3 Dimensions and skips
l3keys.sty    2012/07/15 v3986 L3 Experimental key-value interfaces
l3fp.sty    2012/07/15 v3986 L3 Floating points
l3box.sty    2012/07/15 v3986 L3 Experimental boxes
l3coffins.sty    2012/07/15 v3986 L3 Coffin code layer
l3color.sty    2012/07/15 v3986 L3 Experimental colour support
l3luatex.sty    2012/07/15 v3986 L3 Experimental LuaTeX-specific functions
l3candidates.sty    2012/05/12 v3633 L3 Experimental additions to l3kernel
xparse.sty    2012/07/16 v3990 L3 Experimental document command parser
fontspec-patches.sty    2012/05/06 v2.2b Advanced font selection for 
XeLaTeX/Lu aLaTeX
fixltx2e.sty    2006/09/13 v1.1m fixes to LaTeX
fontspec-xetex.sty    2012/05/06 v2.2b Advanced font selection for     
eu1enc.def    2010/05/27 v0.1h Experimental Unicode font encodings
eu1lmr.fd    2009/10/30 v1.6 Font defs for Latin Modern
xunicode.sty    2011/09/09 v0.981 provides access to latin accents and many
other characters in Unicode lower plane
eu1lmss.fd    2009/10/30 v1.6 Font defs for Latin Modern
graphicx.sty    1999/02/16 v1.0f Enhanced LaTeX Graphics (DPC,SPQR)
keyval.sty    1999/03/16 v1.13 key=value parser (DPC)
graphics.sty    2009/02/05 v1.0o Standard LaTeX Graphics (DPC,SPQR)
trig.sty    1999/03/16 v1.09 sin cos tan (DPC)
graphics.cfg    2010/04/23 v1.9 graphics configuration of TeX Live
xetex.def    2009/11/22 v0.94 LaTeX color/graphics driver for XeTeX (RRM/JK)
xkeyval.sty    2008/08/13 v2.6a package option processing (HA)
xkeyval.tex    2008/08/13 v2.6a key=value parser (HA)
microtype.sty    2011/08/18 v2.5 <beta-07> Micro-typographical refinements 
microtype-xetex.def    2011/08/18 v2.5 <beta-07> Definitions specific to
xetex (RS)
microtype.cfg    2011/08/18 v2.5 <beta-07> microtype main configuration 
file (RS)
t3cmr.fd    2001/12/31 TIPA font definitions
mt-MinionPro.cfg    2005/02/07 v1.0 microtype config file for MinionPro
mt-cmr.cfg    2011/04/09 v2.1 microtype config. file: Computer Modern 
  • Interesting. Although I don't have Minion Pro installed. Have you tried other fonts? I tried it with Times New Roman and it works fine. What operating system do you use?
    – hpesoj626
    Commented Sep 18, 2012 at 0:06
  • I tried it both on ubuntu 10.04 and Vista,the same result. Setting font size to 12pt works fine, the same for 10pt, but 11pt fails (via \fontsize)
    – pml
    Commented Sep 18, 2012 at 7:10
  • How about other fonts? I haven't tried vista for like eternity (and don't want to try it again). I am on Ubuntu 12.04. I tried compiling your code with Times New Roman and xelatex and it works fine.
    – hpesoj626
    Commented Sep 18, 2012 at 8:00
  • I've tried with Linux Libertine, the same problem. Make sure you use the version of microtype that supports XeLaTeX (2.5), when compiling with the older version, microtype is ignored and proccess goes fine. However, I need both microtype, mathspec and 10.5pt size font in the document
    – pml
    Commented Sep 18, 2012 at 8:26
  • Put \listfiles in your preamble, compile and open your log file. At near the end of the file, you will see the version numbers of the packages that you have installed. You can edit your question and include the version numbers.
    – hpesoj626
    Commented Sep 18, 2012 at 8:53

2 Answers 2


do not redefine \normalsize. Use the optional argument Scale:

\setmainfont[Numbers=Lining, Ligatures=TeX, Scale=1.05]{Minion Pro}

and for another line spacing use package setspace, if needed. However, if you prefer the redefining of \normalsize then use:


\setmainfont[Numbers=Lining, Ligatures=TeX]{Minion Pro}
\setmathfont(Digits,Greek,Latin)[Numbers=Lining]{Minion Pro}
   \abovedisplayskip 10\p@ \@plus2\p@ \@minus5\p@
   \abovedisplayshortskip \z@ \@plus3\p@
   \belowdisplayshortskip 6\p@ \@plus3\p@ \@minus3\p@
   \belowdisplayskip \abovedisplayskip

\sum_{i=1}^\infty \alpha^i

  • thanks, it works. I cann't use grid package, but its ok. Regards
    – pml
    Commented Sep 18, 2012 at 9:56

I also had the same problem. Inserting fix-cm package fixed it.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .