6

I'm trying to add a watermark to my paper, simply by adding a

 \usepackage{draftwatermark}

But the watermark doesn't appear to be showing up?

On closer inspection, it's there, but offset from the page, so it only just shows in one corner.

Any ideas? I'm using a journal specific style class (MNRAS / mn2e.cls).

A MWE:

\documentclass{mn2e}
\usepackage{draftcopy}
\usepackage{lipsum}

\begin{document}

\lipsum[1-11]

\end{document}

enter image description here

2
  • 4
    Can you provide us with a minimal working example, please? Sep 19, 2012 at 18:00
  • 1
    I took the liberty of adding a MWE (and an image of the resulting document) illustrating the problem mentioned; I hope it's OK. Sep 20, 2012 at 3:07

2 Answers 2

3

Figured it out eventually. According to the documentation, draftwatermark

also assumes that \paperwidth and \paperheight are set correctly.

I suspected the journal class file might be doing something weird. Turns out you can enforce the standard page size by including

\usepackage[a4paper]{geometry}

after you set up the document with mn2e.

Here's a fixed MWE, with some draftwatermark options for good measure:

\documentclass{mn2e}

\usepackage[a4paper]{geometry}
\usepackage{draftwatermark}
\SetWatermarkScale{5}
\SetWatermarkLightness{0.9}

\usepackage{lipsum}

\begin{document}
\lipsum[1-11]
\end{document}
1

or set them explicitly

\usepackage{geometry}
\geometry{height=11truein,width=8.5truein}
\usepackage{draftwatermark}\SetWatermarkText{{\ifnum\value{page}>12 Too long \else\fi}}
3
  • 2
    Welcome to TeX.SX! Could you expand your answer by providing a complete example that users may directly paste and compile? See as example TimS's answer. It also makes clear to new users where your proposed solution has to be put in the document. Feb 28, 2014 at 11:15
  • Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. Feb 28, 2014 at 11:37
  • Also rewrite your answer: For me it is not immediately clear what you refer to, because on with my setting your answer appears in the moment before the other one. Something like “In addition to answer of TimS. You can also set papersize explicitly …”
    – Speravir
    Feb 28, 2014 at 19:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.