I've been trying to install the mathabx-type1 font with no sucess on my Ubuntu-Linux distribution. I downloaded the .pfb and .map files from here.

What I did was the following:

  1. First, I had to find where my local texmf folder was. In my case, it is located at /usr/share/texmf.
  2. I created a folder named mathabx-type1 on /usr/share/texmf/fonts/type1/public/, and copied the .pfb files there.
  3. I created a folder named mathabx-type1 on /usr/share/texmf/fonts/map/dvips/, and copied the .map file there.
  4. I ran the command mktexlsr on terminal.
  5. I ran the command updmap-sys on terminal.

The thing is that the update at step 5 doesn't touch the mathabx-type1 folder, but it does update the other folders on the same folder! (that is, it "sees" all the .map files in every folder at /usr/share/texmf/fonts/map/dvips/ except for mathabx-type1). Can anyone tell me what I'm missing here?

  • As HO said, just use updmap-sys --enable Map=mathabx.map. – Leo Liu Sep 20 '12 at 1:37

The following step is missing between 4. and 5.:

updmap-sys --enable Map=mathabx.map

And before 4. the TeX files CTAN:fonts/ps-type1/mathabx/texinputs/* are copied to texmf/tex/latex/mathabx/.

You need also the MetaFont sources. CTAN:fonts/ps-type1/mathabx/sources/* are copied to texmf/fonts/sources/public/mathabx/*. Then the TFM files should be generated automatically if needed.


  • Is your Ubuntu/TeX Live so old that it does not contain mathabx (date on CTAN is 2005)?
  • External packages should not be installed in the distribution tree (/usr/share/texmf looks pretty close to a distribution tree). The next update of the distribution might interfere. A good place (for system-wide installation) is the "local texmf tree", that is the tree that is found by TEXMFLOCAL:

    kpsewhich --var-value TEXMFLOCAL

Further reading: Installing TeX fonts.

  • No, my TeX live distribution DOES contain mathabx, it doesn't have mathabx-type1, which are apparently neccesary to use Tex fonts in the PyX python packages. I'll give a try at your solution and post if it worked here. Thanks ;-). – Néstor Sep 20 '12 at 1:19
  • The Type1 fonts for mathabx were introduced in TeX Live 2010. So it seems to be the well known problem of Ubuntu that still provides TeX Live 2009 by default. – egreg Sep 26 '12 at 11:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.