I am trying to get latex (tetex) working in a recent installation of Zenwalk. The main problem is that tikZ needs to be installed "by hand" because the Zenwalk package manager netpkg can't do it by itself.

As I'm new to linux, advice on how to do this would be much appreciated.

Some information that might be helpful: when I try to build a latex file using Geany, the error message I get refers to the fact that the tikz.sty file can't be found. The file does exist (in the directory /usr/share/texmf/tex/latex/pgf/frontendlayer), but either it's in the wrong place or the compiler doesn't know where to find it. Compilation fails. If I try to compile a latex file that has no tikZ in it, then the file builds just fine, so the rest of latex is running fine.


I would seriously recommend not to use the teTeX packages of Zenwalk. While I have never heard of the Zenwalk distribution before, teTeX is unmaintained since 2006. Its successor is TeX Live. Manually installing TeX Live is easy (just run the installer script and the set $PATH). TeX Live contains the newest TikZ version and all dependencies (maybe you need to run tlmgr update --all after installing to get the newest package versions). Before you install TeX Live you should remove teTeX to avoid any potential problems.

According to the Zenwalk Wiki, this is how you set the path:

After the installation is completed open a text editor such as Geany and create a file called texlive.sh and put the following two lines in it:

export PATH=$PATH:/opt/texlive/2010/bin/i386-linux
export MANPATH=$MANPATH:/opt/texlive/2010/texmf/doc/man

Save texlive.sh file. Make this file executable. Move this file to /etc/profile.d

(as root, afterwards you need to log out and then log in again).

By default TeX Live installs itself to /usr/local/texlive/2010 so you might need to change the paths.

  • Hi Caramdir, I followed your advice, uninstalled teTeX, and installed TeX Live. I also created the texlive.sh document, put it in the right place, and made it executable. However, when I type tlmgr or mktexslr or texhash, I get the same error message that the command is not found. Maybe I have not changed the paths correctly. – Jasper D'Agostino Dec 19 '10 at 17:03
  • @Jasper: I have never used Zenwalk, so I can't vouch for the correctness of the advice from the Wiki. What is the output of echo $PATH? – Caramdir Dec 19 '10 at 20:34
  • Hi Caramdir, I actually asked the question on behalf of my father, who is having the problems with Zenwalk. When he turned his computer on, so that he could answer your question, he found that the operating system would not boot; when he tried to change the paths, he must have really messed things up. He's now thinking about whether he should just wipe his system and start from scratch, maybe with a more friendly version of linux. So I will accept your answer while he figures out what to do with his machine. – Jasper D'Agostino Dec 20 '10 at 5:20
  • Ouch. You could try to boot from some Live Disk (most distros nowadays come with one) and try to correct the problem. – Caramdir Dec 20 '10 at 16:50
  • Hi Caramdir, I managed to get the Zenwalk going again, by deleting a bad path entry, and then I also managed to change the path correctly so that the texlive also works. Thanks again for your help. – Jasper D'Agostino Dec 21 '10 at 3:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.