2

The simple expression:

$v_f = \SI[per-mode=fraction]{32}{\meter\per\second}$

when parsed, yields the following error:

! Package xkeyval Error: `per-mode' undefined in families `key'.

However, removing [per-mode=fraction] causes it to work fine. How can I print this as a fractional unit?

5
  • 4
    You're probably using an old version of siunitx. Try updating to the current version (2.5c).
    – Jake
    Commented Sep 22, 2012 at 23:02
  • @Jake How do I determine the version?
    – lily
    Commented Sep 22, 2012 at 23:05
  • @Jake Okay, I've got version 1.3. I installed siunitx by installing the texlive-science package, so what is the best way of updating?
    – lily
    Commented Sep 22, 2012 at 23:11
  • 3
    @Arafinwe If you're using the TeX Live 2009 that's provided by Debian/Ubuntu you're out of luck. You can install the 2012 version with this PPA, but this method doesn't guarantee that the last version of packages is in the distribution. You may want to install a "vanilla TeX Live"
    – egreg
    Commented Sep 22, 2012 at 23:16
  • @Jake Thanks for your comment. If you should re-post that as an answer, I would accept it.
    – lily
    Commented Sep 23, 2012 at 1:11

1 Answer 1

2

The comments have suggested upgrade your siunitx, but that may not be so easy. The option for version one was called just per

\documentclass{article}
\usepackage{siunitx}
\sisetup{per = fraction}
\begin{document}
$v_f = \SI{32}{\meter\per\second}$
\end{document}

If you give a version one option in the preamble, version two will pick this up an act appropriately.

0

Not the answer you're looking for? Browse other questions tagged .