7

OK, this I cannot really understand..

Basically, I use scite that calls a lua script, and through that, pdflatex. (If scite is ran from a terminal, then the pdflatex output called through it is dumped to the same terminal, and then one can also interact with pdflatex, in case of errors)

Today, I added to one of my files:

\showthe\paperheight
\showthe\pdfpageheight
\showthe\paperwidth
\showthe\pdfpagewidth

... and I'd run pdflatex as usual - and I'd notice this in the log:

? > 0.0pt.
l.6 \showthe\paperheight

? > 845.04684pt.
l.7 \showthe\pdfpageheight

? > 0.0pt.
l.8 \showthe\paperwidth

? > 597.50787pt.
l.9 \showthe\pdfpagewidth

... and pdflatex kept on going, and all was fine.

Then, I keep working - and suddenly, pdflatex does not run over the \showthe commands anymore; instead, it starts waiting for a user input! Here I'd answer with 'scroll', i.e.

? > 845.04684pt.
l.7 \showthe\pdfpageheight

? S
OK, entering \scrollmode...
> 0.0pt.
l.8 \showthe\paperwidth

> 597.50787pt.
l.9 \showthe\pdfpagewidth

... and then it would run through the end!

Now, I am forced to call pdflatex like:

pdflatex -interaction=scrollmode file.tex ...

... so as to cause pdflatex to 'run through' these commands - but now I'm afraid it will not stop on some more serious error (where I'd otherwise prefer it to stop).

Does anyone have an idea about what happened here - and how do I get my old pdflatex behavior back?

$ pdflatex --version
pdfTeX 3.1415926-1.40.10-2.2 (TeX Live 2009)
kpathsea version 5.0.0
$ uname -r
2.6.32-26-generic

Thanks in advance,

Cheers!

1

1 Answer 1

15

That is the default behaviour. Use

\the\paperheight

or if you want it only in the terminal output or logfile

\typeout{=== \the\paperheight ===}%
2
  • Thanks @Herbert! Wasn't sure really what was the default behavior... Now, I'd just need to discover how come pdflatex behaved as it did, without any particular command line switches ?! Thanks in any case...
    – sdaau
    Dec 19, 2010 at 15:55
  • \scrollmode in the code triggers the same behavior as the flag --interaction=scrollmode.
    – Philipp
    Dec 19, 2010 at 19:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .