4

I'm using the book document class and the babel package with the spanish option, I have a ToC like this:

  1. CHAPTER NAME
    1.1. SECTION NAME
    1.1.1. Subsection name
    1.1.1.1. Subsubsection name

How can I remove the dot after sections numbers, tables numbers on LoT and figure numbers on LoF?.

P.S.: The Chapter number should have a dot.

Here a MWE

\documentclass{book}
\usepackage[spanish,es-lcroman]{babel}

\setcounter{secnumdepth}{4}
\setcounter{tocdepth}{4}
\makeatletter
\def\@seccntformat#1{\csname the#1\endcsname\quad}
\makeatother

\begin{document}

\tableofcontents

\listoftables

\listoffigures

\chapter{CHAPTER NAME}

\section{SECTION NAME}

\subsection{Subsection name}

\subsubsection{Subsubsection name}

\begin{table}
    My table
    \caption{Table}
\end{table}

\begin{figure}
    My figure
    \caption{Figure}
\end{figure}

\end{document}

Note that I'm using the code:

\makeatletter
\def\@seccntformat#1{\csname the#1\endcsname\quad}
\makeatother

to remove the dot after sections number in the document.

1
  • 1
    Thanks for the MWE; I took the liberty and removed some things from it that aren't relevant to your problem, in order to make it somewhat more of a real minimal working example.
    – doncherry
    Sep 25, 2012 at 21:42

1 Answer 1

8

The Spanish module for babel is responsible for this, probably following some directive of the authority on the language. There is an additional option for disabling it:

\usepackage[spanish,es-lcroman,es-nosectiondot]{babel}

See section 2.3 in the documentation for the Spanish option (texdoc spanish or here on TeXdoc.net).

There will be no need to act on \@seccntformat.

In order to keep the period after the chapter number (although I don't see why), patch the \@chapter command:

\usepackage{etoolbox}
\makeatletter
\patchcmd\@chapter{\numberline{\thechapter}}{\numberline{\thechapter.}}{}{}
\makeatother
8
  • Thanks egreg, this is a very good solution. But removes the dot after the Chapter number in TOC. How can I add a dot to this?
    – osjerick
    Sep 25, 2012 at 21:40
  • 1
    ...caused by a redefinition of \numberline: \def\numberline#1{\hb@xt@\@tempdima{#1\if&#1&\else.\fi\hfil}} from the original \def\numberline#1{\hb@xt@\@tempdima{#1\hfil}}
    – Werner
    Sep 25, 2012 at 21:40
  • egreg thanks again, the dot after chapter number is a requirement of the format for my thesis. Thanks!
    – osjerick
    Sep 25, 2012 at 21:50
  • 1
    @osjerick doncherry removed the irrelevant packages from your example and did well. But remember: never pass the pdftex option to graphicx or hyperref.
    – egreg
    Sep 25, 2012 at 21:53
  • @egreg when I use the code es-nosectiondot and \patchcmd@chapter{\numberline{\thechapter}}{\numberline{\thechapter.}}{}{}, the dot in LoF and LoT dissapears, i.e, I want Table 1. instead I have Table 1 and it's same for Figure 1. Can you help me please?
    – Joan
    Feb 21, 2019 at 17:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.