28

The position of Bibliography section is defined by document class, report class is a new page, some articles class no has page break.

How change this witout change the class of the document? So i have a report class but how generate Bibliography without page break.

  • You can check the report source code, find the macro placing the bibliography, and use \renewcommand in your preamble to remove the call to \pagebreak or similar. – T. Verron Sep 27 '12 at 4:28
  • So you want your bibliography to show like a section instead of like a chapter? – Gonzalo Medina Sep 27 '12 at 4:31
  • @GonzaloMedina yes, rigth – white-shy-guy Sep 27 '12 at 4:32
26

Internally, thebibliography environment uses \chapter*; if you want the bibliography to behave like a section, you can patch the \thebibliography command to use \section* instead of chapter*. To do this, add the following lines to the preamble:

\usepackage{etoolbox}
\patchcmd{\thebibliography}{\chapter*}{\section*}{}{}

A complete example:

\documentclass{report}
\usepackage{etoolbox}
\usepackage{lipsum}% just to generate text for the example

\patchcmd{\thebibliography}{\chapter*}{\section*}{}{}

\begin{document}

\lipsum[1]

\begin{thebibliography}{9}
\bibitem{a} Test A.
\end{thebibliography}

\end{document}

enter image description here

If the biblatex package is used to produce the bibliography, one can use \defbibheading to define a heading using \section*:

\documentclass{report}
\usepackage{lipsum}
\usepackage{biblatex}

\addbibresource{biblatex-examples.bib}
\defbibheading{secbib}[\bibname]{%
  \section*{#1}%
  \markboth{#1}{#1}}

\begin{document}

\lipsum[1]
\nocite{*}

\printbibliography[heading=secbib]

\end{document}

enter image description here

  • I there a way to do the same thing if I am using bibtex (not biblatex)? – Seeda Sep 17 '17 at 0:44
17

If you are using the natbib package, you may try the option sectionbib:

\usepackage[sectionbib]{natbib}

  • 2
    This is so much simpler than the top answer 😝 – Yan King Yin Jun 13 '17 at 14:38
  • 1
    Solved a similar issue with the bibentry package – Heather Turner Nov 9 '18 at 15:41
  • Works in conjunction with numbers, as: \usepackage[numbers,sectionbib]{natbib} – maurice Mar 8 at 19:43
7

If the biblatex package is used to produce the bibliography, you can also use one of the predefined headings, i.e. subbibliography

You can refer to section 3.6.8 Bibliography Headings and Environments in the biblatex manual.

  • 4
    This works like a charm, n.b. the actual command is \printbibliography[heading=subbibliography] – Mr. Tao Jul 27 '18 at 0:30
3

bilatex package is useful and very easy in such case. Suppose,

  1. You want a section inside document as well as an un-numbered section entry in table of contents, then use

    \printbibliography[heading=subbibintoc,] % TOC has an entry 'References' as an un-numbered section
    
  2. You just want a section inside document and no entry in table of contents, then use

    \printbibliography[heading=subbibliography,] % No entry in TOC
    

An MWE, borrowed from Gonzalo Medina's answer would be like this:

\documentclass{report}
\usepackage{lipsum}
\usepackage{biblatex}
\addbibresource{biblatex-examples.bib}

\begin{document}
\tableofcontents
\lipsum[1]
\nocite{*}
% un-comment any one from the following as per your choice
%\printbibliography[heading=subbibliography,] % No entry in TOC
%\printbibliography[heading=subbibintoc,] % TOC has an entry 'References' as an un-numbered section
\end{document}
  • 1
    I removed the definition of secbib that remained in the copy of Gonzalo's MWE, it was not used here and would probably only confuse people. – moewe Nov 30 '18 at 12:04
  • 1
    FWIW I think this use of subbibliography or subbibintoc (or subbibnumbered) is generally slightly nicer than a new heading definition such as secbib in simple cases. But in more complicated case a new definition might be inevitable. – moewe Nov 30 '18 at 12:05
0

FWIW, when using the llncs class together with the natbib package, one gets a bibliography on a separate page, listing reference indexed as [1], [2]... instead of 1., 2.... as expected by LNCS.

To avoid that problem, I use:

\usepackage[numbers]{natbib}
% Hack natbib so it matches the LNCS style: reference list in a
% section with small font and no square brackets.
\renewcommand\bibsection
  {\section*{\refname}\small\renewcommand\bibnumfmt[1]{##1.}}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.