5

I'm writing a document using the copernicus_discussions.cls document class. This document class doesn't work when using babel. So I need to keep LyX from automatically using babel. However, even though in Tools->Preferences->Language I selected "Language package: None" and disabled all checkboxes on that page, and even though in my document preferences, I selected "Language package: None", the generated LaTeX source still contains the line

\usepackage{british,english]{babel}

How can I prevent LyX from inserting that line?

  • What's wrong with using babel with natbib? – Joseph Wright Sep 27 '12 at 16:52
  • as I wrote in the question, the copernicus_discussions.cls class doesn't work in conjunction with both natbib and babel. More specifically, LaTeX gets sent into an infinite loop at the first \citet or \citep command. – andreas-h Sep 27 '12 at 17:18
  • I just realized it also happens when using \cite, so it's not natbib dependant – andreas-h Sep 28 '12 at 8:15
  • 1
    There used to be a Lyx mailinglist, some years ago I got a usefull answer there, my question then also aimed at Lyx internals. – Keks Dose Sep 28 '12 at 9:34
  • Links to LyX mailing lists are found at lyx.org/MailingLists – Torbjørn T. Sep 28 '12 at 11:13
9

This is a known bug that will be fixed with LyX 2.0.5

Workaround: In Document Settings (Language), set language package to Custom and insert % dummy (or anything else preceded by a % char) into the custom package input widget.

Related link

  • Confirmed, the same still exists in LyX 2.2.3 (2017-05-17) – sitilge Oct 16 '17 at 12:55
  • @sitilge I have LyX 2.2.3 as well, and that bug does not appear here. Setting the "Language Package" to "None" removes babel from the preamble. – Torbjørn T. Oct 16 '17 at 15:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.