I have been trying for a long time now to install the MathTime Professional II (mtpro2) fonts on my system. (I am running MikTeX 2.9 under Windows 7, but what likely matters is "recent MikTeX, under Windows", which is general enough to be of interest to many people.) I've tried various things:

  1. First step:
    • Merging the "texmf" directory structure into my MikTeX root directory ("C:\Program Files\MiKTeX 2.9") or
    • registering a new root directory ("C:\Local TeX Files") and
      • putting mtpro2's "texmf" directory directly in there or
      • putting the subdirectories of mtpro2's "texmf" directory in there
  2. Second step: Running initexmf --edit-config-file updmap and adding the lines "# MathTimePro II" and "Map mtpro2.map" to the file.
  3. Third step: Running any and all of the following commands in various orders and combinations:
    • From the command prompt (always in Administrator mode (right-click -> "Run as administrator")): updmap, texhash, mktexlsr, initexmf --admin -u
    • Accessing the MikTeX "Options" dialogue (via running MikTeX 2.9 -> Settings as Administrator) and then choosing both "Refresh FNDB" and "Update Formats"

None of this seems to work. Right now the error messages I get when trying to compile the enclosed sample file "MTPro2 LaTeX test.tex" is the following:

!pdfTeX error: pdflatex.exe (file mt2exf): Font mt2exf at 2400 not found

==> Fatal error occurred, no output PDF file produced!

I have no clue what's happening. Also I hope I haven't cluttered the hash/database files with incorrect information in this process.

How do I install the MathTime Professional II fonts under MikTeX?


3 Answers 3


Update: See now the more general tutorial Manual font installation.

I did the following and it worked for me. Some steps may not be necessary or have been done redundantly. I believe I did everything in "user" mode.

  1. Created C:\Local TeX Files
  2. Put zipped fonts distribution in temporary directory and unzipped there
  3. C:\Program Files (x86)\MiKTeX 2.9\miktex\bin opened there mo.exe. changed default format to letter and added to roots C:\Local TeX Files. needed to do show MiKTeX maintained root directories so it is in the right priority among directories. System said it needed to rebuild format files and did so.
  4. Move the contents of the texmf folder to your own root directory (C:\Local TeX Files)
  5. From a command line run

    initexmf --edit-config-file updmap
  6. Empty file opened in notepad

  7. Add the following two lines to the file
    • # MathTimePro II
    • Map mtpro2.map
  8. Save and exit
  9. Do not change cmd directory. From a command line run (this took a long time)

  10. refresh FNDB (user). update formats

  11. do the following two commands on two different lines from command line
    • initexmf --mkmaps
    • updmap
  12. refresh FNDB (user). update formats
  • I followed your instructions (with minor differences in path names on my computer/setup), and things worked! Good job. For me, I'm sure that I had previously done basically all of these (as user or admin) except the line initexmf --mkmaps. Commented Oct 2, 2012 at 7:15
  • When I try to run updmap command in the command line Windows says: Sorry, but mkfntmap did not succeed. The log file hopefully contains the information to get MiKTeX going again: C:/Users/OPTICAMADO/AppData/Local/MiKTeX/2.9/miktex/log/updmap.log You may want to visit the MiKTeX project page, if you need help. What can I do?
    – Dog_69
    Commented Dec 19, 2017 at 21:54
  1. Created C:\Local TeX Files. Put zipped fonts distribution in this directory and unzipped there.

  2. Click Start → Programs → MiKTeX 2.9 → Maintenance → Settings to open the MiKTeX Options window, Click on the Roots tab. The Roots page shows the list of currently registered root directories.

    Click Add. In the following dialog box , browse to C:\Local TeX Files and click OK. The root directory will be appended to the list.

    You can move C:\Local TeX Files before the installation directory, if you want to prioritize your own files. Click C:\Local TeX Files to select the list entry. Then click Up to move it before the installation directory.

  3. In the directory...\miktex 2.9\miktex\bin\x64\ at the command line, Run "initexmf --edit-config-file updmap"

a Notepad window is opened, add the line (no quote):

"Map mtpro2.map #localtexmf\dvips\mtpro2\mtpro2.map"

Then save and exit.

  1. In the directory...\miktex 2.9\miktex\bin\x64... Run updmap.exe

  2. Do somethings as the step 2, Click on the General tab, click Refresh FNDB, click Update Formats.


The problem I've found is that the installation puts updmap.cfg in the wrong directory. Here are my notes (which do work, eventually).

General strategy for getting mtpro fonts to work.

  • Run updmap --verbose from a dos box.

  • Run initexmf --edit-config-file updmap from a dos box.

  • Make sure Document and Settings/All Users/Application Data/Miktex/2.9/miktex/config contains the file updmap.cfg with the correct contents.

Note: the installation puts it in myname/Application Data/MiKTeX/2.9/miktex/config/

Put in All Users. This seems to have done the trick.

  • It seems you mixed up administrative and user mode installation, cf. Difference between administrative and user mode of MiKTeX.
    – Speravir
    Commented Sep 30, 2012 at 23:47
  • @Speravir Not my mix up --- I installed it for all users, but then initexmf assumed otherwise. Until I moved the file, I got the same error as OP.
    – anon
    Commented Oct 1, 2012 at 0:31
  • No: You didn’t add the option --admin, so you were in user mode.
    – Speravir
    Commented Oct 1, 2012 at 22:14
  • @Speravir I'm upvoting this because it draws attention to what on my setup seems to have to do with so-called "shadow copies" that Windows makes in the mysterious and hidden "C:\Users\<username>\AppData" directory. I know that this may be covered by Speravir's links, so anyone feel free to add info or edit things to clarify my understanding. Commented Oct 2, 2012 at 7:22
  • Please can anyone guide me through this process? I am finding it really difficult to load mtpro2 and I don't understand your comments. Commented Mar 27, 2022 at 7:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .